aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNavid Afkhami <navid.afkhami@mdc-berlin.de>2023-02-16 16:45:23 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-02-16 16:56:11 +0100
commit312f1f41d3f3f3e5d2c36ff46920c6dce1c21a17 (patch)
tree96a3599d027f90e86a4cdd618c12c40efed84e3f
parentb6a4fbb488f1f539ae45ed7924c9af8905fa0d8b (diff)
downloadguix-312f1f41d3f3f3e5d2c36ff46920c6dce1c21a17.tar.gz
guix-312f1f41d3f3f3e5d2c36ff46920c6dce1c21a17.zip
gnu: Add r-changepoint.
* gnu/packages/cran.scm (r-changepoint): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b4dc7822f2..6cea202519 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -283,6 +283,29 @@ simulating diversification models, dating trees, comparing trees, and
reading/writing trees in Newick format.")
(license license:gpl2+)))
+(define-public r-changepoint
+ (package
+ (name "r-changepoint")
+ (version "2.2.4")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "changepoint" version))
+ (sha256
+ (base32
+ "16v4p2c9zi2w3anwf5y9snl5dy1g5aidiqz1vn2p64qhfvg6yqxc"))))
+ (properties `((upstream-name . "changepoint")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-zoo))
+ (home-page "https://github.com/rkillick/changepoint/")
+ (synopsis "Methods for changepoint detection")
+ (description
+ "Changepoint implements various mainstream and specialised changepoint
+methods. These methods are suitable for finding single and multiple
+changepoints within data. Many popular non-parametric and frequentist methods
+are included as well.")
+ ;; Any version of the GPL.
+ (license license:gpl3+)))
+
(define-public r-collections
(package
(name "r-collections")