aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-12-17 13:08:15 +0100
committerRicardo Wurmus <rekado@elephly.net>2025-01-20 21:37:23 +0100
commit30cc0d4b88b5ff20362692334acccdf4d777ba1e (patch)
tree2af956c395216a2cefe72532ece1c240e8b4ae3d
parent7548058ae4615af8e5ffb2e95a4572ec4bbfda54 (diff)
downloadguix-30cc0d4b88b5ff20362692334acccdf4d777ba1e.tar.gz
guix-30cc0d4b88b5ff20362692334acccdf4d777ba1e.zip
gnu: python-uvicorn: Update to 0.34.0.
* gnu/packages/python-web.scm (python-uvicorn): Update to 0.34.0. [native-inputs]: Add nss-certs-for-test. Change-Id: I48825939c91464c132a9ee85a986a39173f6854e
-rw-r--r--gnu/packages/python-web.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 35421c8474..33ba79cca5 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6870,7 +6870,7 @@ and fairly speedy.")
(define-public python-uvicorn
(package
(name "python-uvicorn")
- (version "0.32.1")
+ (version "0.34.0")
(source
(origin
;; PyPI tarball has no tests.
@@ -6880,7 +6880,7 @@ and fairly speedy.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0mrp87l2d5k2dcz07wj2vysjsa99lw5xp12a1a2xiciahg04w7ib"))))
+ (base32 "05lkxnpzmr0kik81kdcvavjvvc4d1lgmw88mr4vbwsqk147wgqbc"))))
(build-system pyproject-build-system)
(arguments
(list
@@ -6893,7 +6893,8 @@ and fairly speedy.")
;; Maybe this <https://github.com/encode/uvicorn/issues/2466>.
"--ignore=tests/supervisors/test_multiprocess.py")))
(native-inputs
- (list python-a2wsgi
+ (list nss-certs-for-test
+ python-a2wsgi
python-hatchling
python-httpx-bootstrap
python-pytest