aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2025-02-02 01:00:00 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2025-02-09 01:00:00 +0100
commit30719e5ef105547c4cf272c9cc55488782ca1a0b (patch)
tree9ae0a050c5c49cf1a256fc5dca43c2b1d2c1e0d5
parentb58c78093e8f25ccb855ef6e94f514f821d20ac3 (diff)
downloadguix-30719e5ef105547c4cf272c9cc55488782ca1a0b.tar.gz
guix-30719e5ef105547c4cf272c9cc55488782ca1a0b.zip
gnu: cpupower: Fix build after Linux 6.14 release.
This should not break older kernel's versions. * gnu/packages/linux.scm (cpupower)[arguments]: Set $CC. Remove obsolete /bin/pwd fix. [native-inputs]: Add which. Change-Id: I9c04fbce40bb6b503a4d3f236bb1f1976173f804
-rw-r--r--gnu/packages/linux.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index f1e0778f37..ce0d37b11b 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7221,12 +7221,12 @@ from that to the system kernel's @file{/dev/random} machinery.")
(build-system gnu-build-system)
(arguments
(list #:make-flags
- #~(list (string-append "DESTDIR=" #$output)
+ #~(list "CC=gcc"
+ (string-append "DESTDIR=" #$output)
(string-append "LDFLAGS=-Wl,-rpath=" #$output "/lib")
- "libdir=/lib"
- "docdir=/share/doc/cpupower"
+ "docdir=/share/doc/cpupower" ;drop default ‘packages/’
"confdir=$(docdir)/examples"
- ;; The Makefile recommends the following changes
+ ;; The Makefile recommends the following changes.
"DEBUG=false"
"PACKAGE_BUGREPORT=bug-guix@gnu.org")
#:tests? #f ; no tests
@@ -7240,10 +7240,11 @@ from that to the system kernel's @file{/dev/random} machinery.")
(lambda _
(substitute* "Makefile"
(("/usr/") "/")
- (("/bin/(install|pwd)" _ command) command))
+ (("/bin/(install)" _ command) command))
(substitute* "bench/Makefile"
(("\\$\\(CC\\) -o") "$(CC) $(LDFLAGS) -o")))))))
- (native-inputs (list gettext-minimal))
+ (native-inputs (list gettext-minimal
+ which)) ;to find gettext
(inputs (list pciutils))
(home-page (package-home-page linux-libre))
(synopsis "CPU frequency and voltage scaling tools for Linux")