aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2020-09-17 14:24:50 +0530
committerArun Isaac <arunisaac@systemreboot.net>2020-10-12 11:41:52 +0530
commit2f5987aebaaa95f879e80175335eb2dbf7161439 (patch)
treee18e3723ba00e0b997f062ed9f02837f5c2b0224
parent7e7c4c685bb60a3f386a3ce2cb9f2c1aa7040c8e (diff)
downloadguix-2f5987aebaaa95f879e80175335eb2dbf7161439.tar.gz
guix-2f5987aebaaa95f879e80175335eb2dbf7161439.zip
gnu: Add rust-ghash-0.3.
* gnu/packages/crates-io.scm (rust-ghash-0.3): New variable.
-rw-r--r--gnu/packages/crates-io.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 5ff08a3ada..4de391abd4 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -9354,6 +9354,32 @@ retrieving random data from system source.")
@acronym{GFA, Graphical Fragment Assembly} format.")
(license license:expat)))
+(define-public rust-ghash-0.3
+ (package
+ (name "rust-ghash")
+ (version "0.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "ghash" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0c957q9sk1q93pqqfvhcmflfm1zvbr14aznfpm25kqd6i437zqnn"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-polyval" ,rust-polyval-0.4)
+ ("rust-zeroize" ,rust-zeroize-1))
+ #:cargo-development-inputs
+ (("rust-hex-literal" ,rust-hex-literal-0.1))))
+ (home-page "https://github.com/RustCrypto/universal-hashes")
+ (synopsis "Universal hash over GF(2^128)")
+ (description "This package provides a universal hash over GF(2^128) useful
+for constructing a Message Authentication Code (MAC), as in the AES-GCM
+authenticated encryption cipher.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-gimli-0.20
(package
(name "rust-gimli")