aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSören Tempel <soeren@soeren-tempel.net>2024-07-11 23:27:17 +0200
committerjgart <jgart@dismail.de>2024-07-13 09:59:21 -0500
commit2ef047f678ee1d253e28f98857c6d99b81952d56 (patch)
tree8553301bf15cb60155b153bef51a6fd7a1cec63e
parentf69a5ede640bba3faa2072c5c80e7961fb9da8cf (diff)
downloadguix-2ef047f678ee1d253e28f98857c6d99b81952d56.tar.gz
guix-2ef047f678ee1d253e28f98857c6d99b81952d56.zip
gnu: Add python-claripy.
* gnu/packages/python-xyz.scm (python-claripy): New variable. Signed-off-by: jgart <jgart@dismail.de>
-rw-r--r--gnu/packages/python-xyz.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a5db502364..6fbd34dbd5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -33790,6 +33790,46 @@ instructions up to AVX-512 and SHA (including 3dnow!+, XOP, FMA3, FMA4, TBM
and BMI2).")
(license license:bsd-2))))
+(define-public python-claripy
+ (package
+ (name "python-claripy")
+ ;; Must be the same version as python-angr.
+ (version "9.2.46")
+ (source
+ (origin
+ ;; Fetching from Git as pypi release doesn't include all test files.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/angr/claripy")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0nmawpi1596d9plafrp2db36cjsidy2fagkzkja51jwlx2m1ngai"))
+ (modules '((guix build utils)))
+ (snippet '(begin
+ (substitute* "setup.cfg"
+ ;; Relax the z3 version constraint.
+ ;; See https://github.com/angr/claripy/commit/d1fe2df
+ (("z3-solver==4.10.2.0")
+ ""))))))
+ (build-system pyproject-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion "tests"
+ (invoke "python" "-m" "unittest"))))))))
+ (propagated-inputs (list python-cachetools python-decorator python-pysmt
+ z3))
+ (home-page "https://github.com/angr/claripy")
+ (synopsis "Abstraction layer for constraint solvers")
+ (description
+ "This Python module provides an abstraction layer for interacting
+with constraint solvers. Specifically, it is intended to be used with
+SMT solvers and is built on top of the Z3 solver.")
+ (license license:bsd-2)))
+
(define-public python-pysmt
(package
(name "python-pysmt")