aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-13 00:43:52 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:17:23 +0200
commit2ed97a41ca668ded9c2cffd6cc205dcc41e19210 (patch)
treef04b2d6ea2f88fb8dd5ebbf114eea4c0dbbaf9c8
parent605f03c900f479deb623a43408da932b799f9448 (diff)
downloadguix-2ed97a41ca668ded9c2cffd6cc205dcc41e19210.tar.gz
guix-2ed97a41ca668ded9c2cffd6cc205dcc41e19210.zip
gnu: Add texlive-luamesh.
* gnu/packages/tex.scm (texlive-luamesh): New variable.
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 7348a93fd1..c3281dcbaf 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2523,6 +2523,29 @@ chiefly useful for examples, but also has macros for particular types of boxes
which are useful on their own.")
(license license:lppl1.3+)))
+(define-public texlive-luamesh
+ (package
+ (name "texlive-luamesh")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/lualatex/luamesh/" "metapost/luamesh/"
+ "scripts/luamesh/" "tex/lualatex/luamesh/")
+ (base32
+ "02qq6d51pihkxz4zbcxppikkzpr99mw8kmp64gm986fpcn6k2wns")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/luamesh")
+ (synopsis "Computes and draws 2D Delaunay triangulation")
+ (description
+ "The package allows to compute and draw 2D Delaunay triangulation.
+The algorithm is written with Lua, and depending upon the choice of the
+engine, the drawing is done by MetaPost (with @code{luamplib}) or by TikZ.
+The Delaunay triangulation algorithm is the Bowyer and Watson algorithm.
+Several macros are provided to draw the global mesh, the set of points, or
+a particular step of the algorithm.")
+ (license license:lppl1.3+)))
+
(define-public texlive-mflogo
(package
(name "texlive-mflogo")