aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-10-31 19:19:29 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-11-01 04:34:24 +0100
commit2ea678fabfb57b05652fa8e0afe8fb6b1000473f (patch)
treea5853bd377c2407c43717aefbb701ceb63aab5a0
parent4fbcfc148264b1ad97706d366dbd94ce4e02e56d (diff)
downloadguix-2ea678fabfb57b05652fa8e0afe8fb6b1000473f.tar.gz
guix-2ea678fabfb57b05652fa8e0afe8fb6b1000473f.zip
gnu: motion: Don't use unstable tarball.
* gnu/packages/video.scm (motion)[source]: Use GIT-FETCH and GIT-FILE-NAME.
-rw-r--r--gnu/packages/video.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 900198a7a7..2eb79a88ff 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2915,14 +2915,14 @@ It counts more than 100 plugins.")
(version "4.2")
(home-page "https://motion-project.github.io/")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/Motion-Project/motion/archive/"
- "release-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Motion-Project/motion.git")
+ (commit (string-append "release-" version))))
(sha256
(base32
- "1ad2zlz941lvb818g1nzlpcpbxgv0h05q164hafa805yqm7m1y3f"))
- (file-name (string-append name "-" version ".tar.gz"))))
+ "0c0q6dl4v561m5y8bp0c0h4p3s52fjgcdnsrrf5ygdi288d3rfxv"))
+ (file-name (git-file-name name version))))
(build-system gnu-build-system)
(native-inputs
`(("autoconf" ,autoconf-wrapper)
s 2020-06-05git-authenticate: Add tests....Ludovic Courtès 2020-05-16gexp: Add 'let-system'....Ludovic Courtès 2020-03-22store: Add 'with-build-handler'....Ludovic Courtès 2020-03-12gexp: Add 'with-parameters'....Ludovic Courtès 2019-11-29ui: Factorize 'with-profile-lock'....Ludovic Courtès 2019-11-19pull: Acquire a lock for the target profile....Ludovic Courtès 2019-09-23git: Add 'commit-difference'....Ludovic Courtès 2019-06-05syscalls: Add 'with-file-lock' macro....Ludovic Courtès 2019-05-27publish: Add support for lzip....Ludovic Courtès 2019-03-07database: Make 'register-items' transactional....Caleb Ristvedt 2019-01-11status: Add 'with-status-verbosity'....Ludovic Courtès 2018-10-19tests: Run 'guix pack' tests using the external store....Ludovic Courtès 2018-09-27Add (guix status) and use it for pretty colored output....Ludovic Courtès 2018-06-01Add (gnu store database)....Caleb Ristvedt 2018-06-01gexp: Add 'with-extensions'....Ludovic Courtès 2018-01-08services: guix: Add 'log-compression' option....Ludovic Courtès 2017-12-01weather: Use (guix progress) for progress report....Ludovic Courtès 2017-05-18union: Gracefully handle dangling symlinks in the input....Ludovic Courtès 2017-05-04dir-locals.el: Add 'modify-phases' keywords....Alex Kost 2017-04-18Add (guix workers)....Ludovic Courtès 2017-01-28Add (guix memoization)....Ludovic Courtès 2016-10-04Set Emacs config variable sentence-end-double-space....Hartmut Goebel 2016-07-19Add (guix zlib)....Ludovic Courtès 2016-07-12gexp: Add 'with-imported-modules' macro....Ludovic Courtès