aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-13 09:12:51 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:17:29 +0200
commit2e669a39bf8fb94509c3087a136e99d3a33f366f (patch)
tree4edc2bdb7708bcbd46e9a9cda96fc75815c38cd3
parent071994bbf177c4e076aba6368813af66c8b2da36 (diff)
downloadguix-2e669a39bf8fb94509c3087a136e99d3a33f366f.tar.gz
guix-2e669a39bf8fb94509c3087a136e99d3a33f366f.zip
gnu: Add texlive-petri-nets.
* gnu/packages/tex.scm (texlive-petri-nets): New variable.
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3c4296b2b3..4f082d0681 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2975,6 +2975,30 @@ themselves can be deformed and will still (hopefully!) fit together in the
correct fashion.")
(license license:lppl1.3c)))
+(define-public texlive-petri-nets
+ (package
+ (name "texlive-petri-nets")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/generic/petri-nets/"
+ "scripts/petri-nets/"
+ "tex/generic/petri-nets/")
+ (base32
+ "0m6qmahbw1q5vs63mr30kf75di86drhi8z3a8p7yn9n524jn435c")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:link-scripts #~(list "pn2pdf")))
+ (inputs (list perl))
+ (home-page "https://ctan.org/pkg/petri-nets")
+ (synopsis "Set TeX/LaTeX packages for drawing Petri nets")
+ (description
+ "Petri-nets offers a set of TeX/LaTeX packages about Petri nets and
+related models. Three packages are available: the first allows the user to
+draw Petri-nets in PostScript documents; the second defines macros related to
+PBC, M-nets and B(PN) models; and a third that combines the other two.")
+ (license license:gpl3+)))
+
(define-public texlive-amiri
(package
(name "texlive-amiri")