aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-05-08 12:06:16 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:45 +0000
commit2e5a8b0ca8196744a771cc21466a0771b12f3ceb (patch)
tree0e8d94867d952e03db37dc0837a0a3eb96b625a0
parentcb91747518f8eeefcbe139eb812115e932b3e612 (diff)
downloadguix-2e5a8b0ca8196744a771cc21466a0771b12f3ceb.tar.gz
guix-2e5a8b0ca8196744a771cc21466a0771b12f3ceb.zip
gnu: python-rope: Update to 1.13.0.
* gnu/packages/python-xyz.scm (python-rope): Update to 1.13.0. [build-system]: Use pyproject-build-system. [arguments]: Remove to enable all tests. [propagated-inputs]: Add python-pytoolconfig. [native-inputs]: Add python-pre-commit, python-pytest-cov, python-setuptools, and python-wheel. Change-Id: I6a114d63cc6a59e292801095bef200cff60eeeff
-rw-r--r--gnu/packages/python-xyz.scm28
1 files changed, 12 insertions, 16 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a24eeb9bf1..b8073d5e60 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -21327,28 +21327,24 @@ respectively.")
(define-public python-rope
(package
(name "python-rope")
- (version "1.1.1")
+ (version "1.13.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "rope" version))
(sha256
(base32
- "0bkzwkllxxdxd3w70xiy137lqvnlmmaplsc2ya3s23ss4kq8y10k"))))
- (build-system python-build-system)
- (arguments
- (list #:phases
- `(modify-phases %standard-phases
- (add-after 'unpack 'disable-broken-test
- (lambda _
- (substitute* "ropetest/contrib/autoimporttest.py"
- (("def test_search_module")
- "def __notest_search_module")
- (("def test_search_submodule")
- "def __notest_search_submodule")))))))
- (native-inputs
- (list python-pytest-timeout
- python-pytest))
+ "1078mkzivz45my8x2y5gxisr0vba630xj7yxx7anr068xhnpshsi"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs
+ (list python-pytoolconfig))
+ (native-inputs
+ (list python-pre-commit
+ python-pytest
+ python-pytest-cov
+ python-pytest-timeout
+ python-setuptools
+ python-wheel))
(home-page "https://github.com/python-rope/rope")
(synopsis "Refactoring library for Python")
(description "Rope is a refactoring library for Python. It facilitates