aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2025-01-08 07:11:39 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2025-03-02 20:31:47 +0100
commit2e1d2543266d713fe528189a96d5379ee67af479 (patch)
treed19e2a5ec0ffe8288283c82e946e91429e536db4
parentf4c242427fcd3a401e6d25417eface630551cab8 (diff)
downloadguix-2e1d2543266d713fe528189a96d5379ee67af479.tar.gz
guix-2e1d2543266d713fe528189a96d5379ee67af479.zip
gnu: libde265: Remove unused qtbase-5 input.
* gnu/packages/video.scm (libde265) [native-inputs]: Improve style. [inputs]: Improve style. Remove qtbase-5 which wasn't actually used (need more inputs to build graphical tools). Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
-rw-r--r--gnu/packages/video.scm13
1 files changed, 4 insertions, 9 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 47b193286f..65ac14cec8 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -717,16 +717,11 @@ applications by providing high-level classes for commonly required tasks.")
`(#:configure-flags
(list "--disable-static")))
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)
- ("pkg-config" ,pkg-config)
- ("python" ,python-wrapper)))
+ (list autoconf automake libtool pkg-config python-wrapper))
(inputs
- `(;; XXX: Build fails with libvideogfx.
- ;; ("libvideogfx" ,libvideogfx)
- ("qt" ,qtbase-5)
- ("sdl" ,sdl)))
+ ;; XXX: Build a complete version using libswscale or libvideogfx
+ ;; and qtbase-5.
+ (list sdl))
(synopsis "H.265 video codec implementation")
(description "Libde265 is an implementation of the h.265 video codec. It is
written from scratch and has a plain C API to enable a simple integration into