aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-15 12:56:26 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:48 +0000
commit2cb863f2c36a7ef3bf30488d640a5a537d9aa7cd (patch)
tree77dd2d19da27a5e80855525033c14171a52b2f18
parent154f7e486524b703ae6eaa754a9ff31f2c85499c (diff)
downloadguix-2cb863f2c36a7ef3bf30488d640a5a537d9aa7cd.tar.gz
guix-2cb863f2c36a7ef3bf30488d640a5a537d9aa7cd.zip
gnu: Add go-github-com-datadog-datadog-go.
* gnu/packages/golang-web.scm (go-github-com-datadog-datadog-go): New variable. Change-Id: Icff31fb07033cc41621835a4f6aa56e6a1e8f9ec
-rw-r--r--gnu/packages/golang-web.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 20b35d5860..5c191a4edf 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -881,6 +881,43 @@ Any}.")
go-golang-org-x-net
go-golang-org-x-oauth2))))
+(define-public go-github-com-datadog-datadog-go
+ (package
+ (name "go-github-com-datadog-datadog-go")
+ (version "4.8.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/DataDog/datadog-go")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "03dc3ld9zyynhmslzlciry6rs06hvd1c5finjip9vj300xaybazl"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/DataDog/datadog-go"
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; XXX: Workaround for go-build-system's lack of Go modules
+ ;; support.
+ (delete 'build)
+ (replace 'check
+ (lambda* (#:key tests? import-path #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion (string-append "src/" import-path)
+ (invoke "go" "test" "-v" "./..."))))))))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (home-page "https://github.com/DataDog/datadog-go")
+ (synopsis "Golang client library to work with DataDog's API")
+ (description
+ "@code{datadog-go} is a library that provides a
+@url{https://docs.datadoghq.com/developers/dogstatsd/?code-lang=go,@code{DogStatsD}}
+client in Golang.")
+ (license license:expat)))
+
(define-public go-github-com-emersion-go-imap
(package
(name "go-github-com-emersion-go-imap")