aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2024-08-22 09:55:38 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2024-08-22 09:55:38 +0200
commit2c7119b43bd44ee812ceaa2351bff9a8b623a920 (patch)
treee436dbdc0d05f02028a31fa1b991876ffeb62175
parenta1d367d6ee8c1783ef94cebbc5f2ae3b7a08078d (diff)
parent9cdad6aeb6b69a8fd0fd37858347d5894bf51ed2 (diff)
downloadguix-2c7119b43bd44ee812ceaa2351bff9a8b623a920.tar.gz
guix-2c7119b43bd44ee812ceaa2351bff9a8b623a920.zip
Merge branch 'lisp-team'
Change-Id: Ib01e9e7efbd59b4a9e21a7c7b46a8159b43e2d79
-rw-r--r--gnu/packages/lisp-xyz.scm13
-rw-r--r--gnu/packages/lisp.scm13
2 files changed, 15 insertions, 11 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index d85f83fbea..e2acf5712f 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -3116,6 +3116,9 @@ package.")
(list sbcl-fiveam))
(inputs
(list sbcl-bordeaux-threads))
+ (arguments
+ ;; Disable flaky tests
+ (list #:tests? #f))
(synopsis "Portable channel-based concurrency for Common Lisp")
(description "Common Lisp library for channel-based concurrency. In
a nutshell, you create various threads sequentially executing tasks you need
@@ -4796,8 +4799,8 @@ from/to strings, streams and files.")
(sbcl-package->ecl-package sbcl-cl-csv))
(define-public sbcl-cl-data-structures
- (let ((commit "25dd479377eb40ce54eed4ecc0d660aed32f3a78")
- (revision "1"))
+ (let ((commit "ffab56830f3ed777450a065890484ef22147cd44")
+ (revision "2"))
(package
(name "sbcl-cl-data-structures")
(version (git-version "1.4.1" revision commit))
@@ -4809,7 +4812,7 @@ from/to strings, streams and files.")
(commit commit)))
(file-name (git-file-name "cl-data-structures" version))
(sha256
- (base32 "1yhfahnsx56s9jzdk7jnqic5a3fiq29i1a9d0ay6fd1rg2wfa3k3"))))
+ (base32 "0h49h1x9dgr53imj0r4lgx0zvdsv3mnh7lyayzy9hlysy2ixp425"))))
(build-system asdf-build-system/sbcl)
(native-inputs
(list sbcl-prove))
@@ -17681,7 +17684,7 @@ and @code{kqueue(2)}), a pathname library and file-system utilities.")
(define-public sbcl-ironclad
(package
(name "sbcl-ironclad")
- (version "0.60")
+ (version "0.61")
(source
(origin
(method git-fetch)
@@ -17689,7 +17692,7 @@ and @code{kqueue(2)}), a pathname library and file-system utilities.")
(url "https://github.com/sharplispers/ironclad/")
(commit (string-append "v" version))))
(sha256
- (base32 "122ldxiddkscb3li5wjrppr7vyn77znyjfgs8pbflrskzyxlabdd"))
+ (base32 "1yszjy6a0q1jvdgd7fpmnvi9851s8ivp4plscw27lbnl7jlj1pmk"))
(file-name (git-file-name "cl-ironclad" version))))
(build-system asdf-build-system/sbcl)
(native-inputs
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 543ceb9953..4f2e61733d 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -429,8 +429,8 @@ interface.")
"--reproducible-build"
"--package-path=/"
(string-append "--bin-path=" out "/bin")
- (string-append "--lib-path=" out "/lib")
- (string-append "--share-path=" out "/share")))))
+ (string-append "--lib-path=" out "/lib/clasp")
+ (string-append "--share-path=" out "/share/clasp")))))
(replace 'build
(lambda* _
(invoke "ninja" "-C" "build")))
@@ -1353,14 +1353,14 @@ be built as a stand-alone REPL interpreter.")
(define-public sbcl
(package
(name "sbcl")
- (version "2.4.5")
+ (version "2.4.7")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/sbcl/sbcl/" version "/sbcl-"
version "-source.tar.bz2"))
(sha256
- (base32 "1lbvb9rzlkl3h8s75i2js4dnmgxmvs41jxjb5dj0f603r688xxjd"))
+ (base32 "1lhia29g0byj7w3akd99sjb8kxp95adwqk2kbl0wsnk30cjlsm38"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -1506,8 +1506,9 @@ be built as a stand-alone REPL interpreter.")
`("clisp")))
(string-append "--prefix="
(assoc-ref outputs "out"))
- ,@(if (target-ppc32?)
- ;; 3072 is too much for this architecture.
+ ,@(if (or (target-ppc32?)
+ (target-x86-32?))
+ ;; 3072 is too much for these architectures.
`("--dynamic-space-size=2048")
`("--dynamic-space-size=3072"))
"--with-sb-core-compression"