aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-10 00:53:52 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:54 +0000
commit2b028a5bf048fff4677e8eb1245d1d3684da595e (patch)
tree915c6da7d7cf589f0b76ef37692d53067cc8f514
parent8510f16003cd9f5094551d450f6b45c44874a9dc (diff)
downloadguix-2b028a5bf048fff4677e8eb1245d1d3684da595e.tar.gz
guix-2b028a5bf048fff4677e8eb1245d1d3684da595e.zip
gnu: python-jaraco-test: Move to pyproject-build-system.
* gnu/packages/python-xyz.scm (python-jaraco-test): [build-system]: Move to pyproject-build-system. [arguments]: Convert <#:phases> to <#:test-flags>. Change-Id: I926671bc2bb62abae24c26a4bddc304133b2c019 Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/python-xyz.scm6
1 files changed, 1 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ad671ebe4e..458433190c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12344,11 +12344,7 @@ releases.")
"0h0x8qmvfkfqvwdx2m7kwhn53sg26k8gkaas7s1730ak772zqrvz"))))
(build-system pyproject-build-system)
(arguments
- (list
- #:phases #~(modify-phases %standard-phases
- (replace 'check
- (lambda _
- (invoke "pytest" "-vv" "-k" "http"))))))
+ (list #:test-flags '(list "-k" "http")))
(propagated-inputs (list python-jaraco-context python-jaraco-functools))
(native-inputs (list python-flake8
python-pytest