aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-03-16 17:54:38 +0100
committerJulien Lepiller <julien@lepiller.eu>2018-05-09 13:37:11 +0200
commit2af51fd06774232922ce302e8617cf9573a96491 (patch)
tree6be9614b83ef7dc4694676dc1a080d078c3bb10d
parent107ebf7b34e619de9f6b50996ede6c7c0e1159cb (diff)
downloadguix-2af51fd06774232922ce302e8617cf9573a96491.tar.gz
guix-2af51fd06774232922ce302e8617cf9573a96491.zip
gnu: Add groovy-sql.
* gnu/packages/groovy.scm (groovy-sql): New variable.
-rw-r--r--gnu/packages/groovy.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/groovy.scm b/gnu/packages/groovy.scm
index 3f7c78a998..4d67010f0d 100644
--- a/gnu/packages/groovy.scm
+++ b/gnu/packages/groovy.scm
@@ -933,3 +933,39 @@ the functionality of the common library of Java.")))
(synopsis "Groovy's servlet implementation")
(description "This package contains a library to create groovlets, Groovy's
version of Java servlets.")))
+
+(define groovy-sql
+ (package
+ (inherit groovy-bootstrap)
+ (name "groovy-sql")
+ (arguments
+ `(#:jar-name "groovy-sql.jar"
+ #:test-dir "src/test"
+ #:tests? #f;TODO: Requires hsqldb
+ #:jdk ,icedtea-8
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'chdir
+ (lambda _
+ (chdir "subprojects/groovy-sql")
+ #t))
+ (replace 'build
+ (lambda _
+ (mkdir-p "build/classes")
+ (mkdir-p "build/jar")
+ (apply invoke "java" "-cp" (getenv "CLASSPATH")
+ "org.codehaus.groovy.tools.FileSystemCompiler"
+ "-d" "build/classes" "-j"; joint compilation
+ (find-files "src/main"
+ ".*\\.(groovy|java)$"))
+ (invoke "jar" "-cf" "build/jar/groovy-sql.jar"
+ "-C" "build/classes" ".")
+ #t)))))
+ (native-inputs
+ `(("groovy-bootstrap" ,groovy-bootstrap)
+ ("groovy-test" ,groovy-test)
+ ("groovy-tests-bootstrap" ,groovy-tests-bootstrap)
+ ,@(package-native-inputs java-groovy-bootstrap)))
+ (synopsis "Groovy SQL library")
+ (description "This package contains a facade over Java's normal JDBC APIs
+providing greatly simplified resource management and result set handling.")))
='/guix/commit/po/packages?id=75f23951ad1d42f9d236cd11390dab35351083da'>nls: Update 'fr' translation.Ludovic Courtès 2017-07-15nls: Adjust to qemu.scm renaming....This is a followup to 59132b800093e486e4d81aed6b837e9ac76aa86c. * po/packages/POTFILES.in: Remove qemu.scm and add virtualization.scm. 宋文武 2017-06-20gnu: Move contents of zip module into compression module....* gnu/packages/zip.scm (zip, unzip, zziplib, perl-zip): Move to... * gnu/packages/compression.scm: ...here. * gnu/packages/zip.scm: Delete file. * gnu/local.mk (GNU_SYSTEM_MODULES): Unregister deleted file. * po/packages/POTFILES.in: Unregister deleted file. * gnu/packages/{audio, avr, bioinformatics, busybox, cdrom, ci, compression, docbook, documentation, fonts, fpga, game-development, games, gl, gnome, gnuzilla, graphics, guile, haskell, image, java, kodi, ldc, libreoffice, markup, maths, mc, monitoring, music, php, pretty-print, python, scheme, smalltalk, statistics, synergy, tex, textutils, video, web-browsers, xml, zip}.scm, guix/build-system/{ant, font}.scm, guix/{download, packages}.scm: Adapt module import. Arun Isaac 2017-05-23nls: Update 'da' translation.Leo Famulari 2017-05-14maint: Do not update PO files upon "make dist"....This works around a non-determinstic build failure when doing "make distcheck -j4". * po/guix/Makevars (DIST_DEPENDS_ON_UPDATE_PO): New variable. * po/packages/Makevars (DIST_DEPENDS_ON_UPDATE_PO): New variable. Ludovic Courtès 2016-12-19nls: Update 'da' package translation.Ludovic Courtès 2016-12-05nls: Adjust to geeqie.scm removal....This is a followup to d1a5b20081c30da7503201df260cf20b8d0ba633. * po/packages/POTFILES.in: Remove gnu/packages/geeqie.scm. Ludovic Courtès 2016-12-04nls: Adjust to feh.scm renaming....This is a followup to d1a5b20081c30da7503201df260cf20b8d0ba633. * po/packages/POTFILES.in: Remove feh.scm and add image-viewers.scm. Ludovic Courtès 2016-12-04nls: Update 'da' package translation.Marius Bakke 2016-08-04nls: Adjust to zsh.scm renaming....* po/packages/POTFILES.in: Adjust to zsh.scm renaming in commit 7ccb874a299d6c6d86a3f1625a68c08ed20dbab6. Ludovic Courtès 2016-05-26nls: Adjust to texlive.scm renaming....* po/packages/POTFILES.in: Adjust to texlive.scm rename in commit 8f9ac90182c022c69600f17ef9c1149e029bc301. Ludovic Courtès 2016-03-28nls: Update 'da' translation.Ludovic Courtès 2016-03-03po: Drop removed file 'weechat.scm'....Fixes <http://bugs.gnu.org/22888>. weechat has been merged into 'irc.scm' in e288f007. * po/packages/POTFILES.in: Drop removed file 'weechat.scm'. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Justus Winter 2015-12-06nls: Add Polish translation.Ludovic Courtès 2015-11-01nls: Add Danish translation for packages.Ludovic Courtès 2015-07-19nls: Add package files for translation....* po/packages/POTFILES.in: Add a bunch of files. Ludovic Courtès 2015-05-10nls: Add package files for translation....* po/packages/POTFILES.in: Add a bunch of files. Ludovic Courtès 2015-02-05nls: Update 'eo' translation.Ludovic Courtès 2015-01-27nls: Add a few more package modules for translation....* po/packages/POTFILES.in: List a few more files. Ludovic Courtès