aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 09:44:14 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 09:48:41 +0200
commit2adb68051528398bfd75f1d4716ca656550183af (patch)
treeb2ed9d6c2a293199ceef8c886bedb9329824272a
parentad600f9b1bd5d2e5638c1618253cee679a3e1f2b (diff)
downloadguix-2adb68051528398bfd75f1d4716ca656550183af.tar.gz
guix-2adb68051528398bfd75f1d4716ca656550183af.zip
gnu: Add texlive-xml2pmx.
* gnu/packages/tex.scm (texlive-xml2pmx): New variable.
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index b73560a371..3c07868f36 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -27436,6 +27436,25 @@ correctly; and define two extra commands: @code{\\vfrac} and
@code{\\namedglyph}.")
(license license:lppl1.3c)))
+(define-public texlive-xml2pmx
+ (package
+ (name "texlive-xml2pmx")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/man/man1/xml2pmx.1"
+ "doc/man/man1/xml2pmx.man1.pdf")
+ (base32
+ "1d3ralqh0b71scd59b4hmm707yfrz1rj28ni2lzkhbb1ql73bvah")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/xml2pmx")
+ (synopsis "Convert MusicXML to PMX and MusiXTeX")
+ (description
+ "This program translates MusicXML files to input suitable for PMX and
+MusiXTeX processing.")
+ (license license:gpl3+)))
+
(define-public texlive-xmltexconfig
(package
(name "texlive-xmltexconfig")