aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2014-12-01 00:17:06 -0600
committerEric Bavier <bavier@member.fsf.org>2014-12-09 12:02:08 -0600
commit2aa466247fd037f274ee8c5455b4cde273286aa9 (patch)
tree6c76d58dba10ade0f79bfd498ee1e63f4a5bd1a9
parent8d809faf8cdd4f06ebfbce7d466d67d00ad12869 (diff)
downloadguix-2aa466247fd037f274ee8c5455b4cde273286aa9.tar.gz
guix-2aa466247fd037f274ee8c5455b4cde273286aa9.zip
gnu: Add perl-benchmark-timer.
* gnu/packages/perl.scm (perl-benchmark-timer): New variable.
-rw-r--r--gnu/packages/perl.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 8d71660180..064822e1df 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -161,3 +161,28 @@ SHA-1 message digest algorithm for use by Perl programs.")
(home-page (string-append "http://search.cpan.org/~gaas/Digest-SHA1-"
version "/SHA1.pm"))
(license (package-license perl))))
+
+(define-public perl-benchmark-timer
+ (package
+ (name "perl-benchmark-timer")
+ (version "0.7102")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/D/DC/DCOPPIT/"
+ "Benchmark-Timer-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1gl9ybm9hgia3ld5s11b7bv2p2hmx5rss5hxcfy6rmbzrjcnci01"))))
+ (build-system perl-build-system)
+ ;; The optional input module Statistics::PointEstimation (from
+ ;; Statistics-TTest) lists no license.
+ (synopsis "Benchmarking with statistical confidence")
+ (description
+ "The Benchmark::Timer class allows you to time portions of code
+conveniently, as well as benchmark code by allowing timings of repeated
+trials. It is perfect for when you need more precise information about the
+running time of portions of your code than the Benchmark module will give you,
+but don't want to go all out and profile your code.")
+ (home-page (string-append "http://search.cpan.org/~dcoppit/"
+ "Benchmark-Timer-" version))
+ (license gpl2)))