aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 13:19:45 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 13:37:05 +0200
commit2a674e37126b3e7561a792ffa268a83d3cc45f7d (patch)
tree89c12abc82155ea2b4f32ddfa1779e099c8c57fe
parent3d3fc4510995c8f5cb4af0e83112c9cbd9f0cf99 (diff)
downloadguix-2a674e37126b3e7561a792ffa268a83d3cc45f7d.tar.gz
guix-2a674e37126b3e7561a792ffa268a83d3cc45f7d.zip
gnu: Add texlive-cjkutils.
* gnu/packages/tex.scm (texlive-cjkutils): New variable.
-rw-r--r--gnu/packages/tex.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index d74956b934..83713164a7 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3552,6 +3552,43 @@ Ghostscript.")
adjust locations and kerning of CJK punctuation marks.")
(license license:lppl1.3+)))
+(define-public texlive-cjkutils
+ (package
+ (name "texlive-cjkutils")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/man/man1/bg5conv.1"
+ "doc/man/man1/bg5conv.man1.pdf"
+ "doc/man/man1/cef5conv.1"
+ "doc/man/man1/cef5conv.man1.pdf"
+ "doc/man/man1/cefconv.1"
+ "doc/man/man1/cefconv.man1.pdf"
+ "doc/man/man1/cefsconv.1"
+ "doc/man/man1/cefsconv.man1.pdf"
+ "doc/man/man1/extconv.1"
+ "doc/man/man1/extconv.man1.pdf"
+ "doc/man/man1/hbf2gf.1"
+ "doc/man/man1/hbf2gf.man1.pdf"
+ "doc/man/man1/sjisconv.1"
+ "doc/man/man1/sjisconv.man1.pdf"
+ "hbf2gf/")
+ (base32
+ "0by2g05xv5dndnd78jz9y73fyswqhfvcbzcw8rzhvpvd6inrcdq8")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/cjk")
+ (synopsis "CJK language support")
+ (description
+ "CJK is a macro package for LaTeX, providing simultaneous support for
+various Asian scripts in many encodings (including Unicode): Chinese (both
+traditional and simplified), Japanese, Korean and Thai. A special add-on
+feature is an interface to the Emacs editor (cjk-enc.el) which gives
+simultaneous, easy-to-use support to a bunch of other scripts in addition to
+the above --- Cyrillic, Greek, Latin-based scripts, Russian and Vietnamese are
+supported.")
+ (license license:gpl2)))
+
(define-public texlive-clrscode
(package
(name "texlive-clrscode")