aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-06-27 15:37:44 +0200
committerMarius Bakke <marius@gnu.org>2020-07-02 23:30:21 +0200
commit2a659af50c8a5e3113337b503339ce797b966e1e (patch)
treeabb68c3aa9451dba4f91bd2c99425c98797cc1b4
parentdfa99fcd2797e10e00dc9f6bfc78c1e0a3f9777d (diff)
downloadguix-2a659af50c8a5e3113337b503339ce797b966e1e.tar.gz
guix-2a659af50c8a5e3113337b503339ce797b966e1e.zip
gnu: libyaml: Do not build static libraries.
* gnu/packages/web.scm (libyaml)[arguments]: New field.
-rw-r--r--gnu/packages/web.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index ab680209a9..cb877bcd7e 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1499,6 +1499,8 @@ hash/signatures.")
(base32
"1x4fcw13r3lqy8ndydr3ili87wicplw2awbcv6r21qgyfndswhn6"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags '("--disable-static")))
(home-page "http://pyyaml.org/wiki/LibYAML")
(synopsis "YAML 1.1 parser and emitter written in C")
(description
29 07:50:23 +0300'>2020-07-29examples: Add password for Alice's brother....* gnu/system/examples/desktop.tmpl (users)[bob]: Add password. Oleg Pykhalov 2019-04-10doc: Adjust desktop instructions for GDM....* gnu/system/examples/desktop.tmpl: Adjust comment that referred to SLiM. Ludovic Courtès 2019-04-05services: xorg: Add 'set-xorg-configuration'....* gnu/services/xorg.scm (gdm-service-type)[compose, extend]: New fields. (set-xorg-configuration): New procedure. * doc/guix.texi (Keyboard Layout): Use it. (X Window): Document it. * gnu/system/examples/desktop.tmpl: Add 'keyboard-layout' fields. Ludovic Courtès 2019-03-28system: Fix typo in desktop example....The typo was introduced in 391e0d65d7129d53c025963d2758724e75626eb4. * gnu/system/examples/desktop.tmpl: Use XFCE-DESKTOP-SERVICE-TYPE, not XFCE-DESKTOP-SERVICE. Ludovic Courtès 2019-03-27services: Deprecate 'xfce-desktop-service'....* gnu/services/desktop.scm (xfce-desktop-service-type)[default-value] [description]: New fields. (xfce-desktop-service): Deprecate. * gnu/system/examples/desktop.tmpl: Use the (service …) form. * gnu/installer/services.scm (%desktop-environments): Add TODO comment. * doc/guix.texi (Desktop Services): Adjust accordingly, and fix spelling of "Xfce" throughout. Ludovic Courtès 2019-03-27services: Deprecate 'gnome-desktop-service'....* gnu/services/desktop.scm (gnome-desktop-service-type)[default-value]: New field. (gnome-desktop-service): Deprecate. * gnu/installer/services.scm (%desktop-environments): Use the (service …) form for GNOME. * gnu/system/examples/desktop.tmpl: Likewise. * doc/guix.texi (Desktop Services): Adjust accordingly. Ludovic Courtès 2019-03-25accounts: Add default value for the 'home-directory' field of <user-account>....* gnu/system/accounts.scm (<user-account>)[home-directory]: Mark as thunked and add a default value. (default-home-directory): New procedure. * doc/guix.texi (User Accounts): Remove 'home-directory' from example. * gnu/system/examples/bare-bones.tmpl: Likewise. * gnu/system/examples/beaglebone-black.tmpl: Likewise. * gnu/system/examples/desktop.tmpl: Likewise. * gnu/system/examples/docker-image.tmpl: Likewise. * gnu/system/examples/lightweight-desktop.tmpl: Likewise. * gnu/system/install.scm (installation-os): Likewise. * gnu/tests.scm (%simple-os): Likewise. * gnu/tests/install.scm (%minimal-os, %minimal-os-on-vda): (%separate-home-os, %encrypted-root-os, %btrfs-root-os): Likewise. * tests/accounts.scm ("allocate-passwd") ("allocate-passwd with previous state"): Likewise. Ludovic Courtès 2019-01-23gnu: Replace all cons* with beginner-friendly (append (list ...))....* gnu/system/examples/bare-bones.tmpl (services): Do it. * gnu/system/examples/beaglebone.tmpl (packages): Do it. (services): Do it. * gnu/system/examples/desktop.tmpl (packages): Do it. (services): Do it. * gnu/system/examples/lightweight-desktop.tmpl (file-systems): Do it. (packages): Do it. * gnu/system/examples/vm-image.tmpl (packages): Do it. Pierre Neidhardt 2019-01-23gnu: Fix missing EFI entry in "desktop" example....* gnu/system/examples/desktop.tmpl (file-systems): Add EFI file-system. Pierre Neidhardt 2018-12-03doc: Fix "desktop" OS config example....* gnu/system/examples/desktop.tmpl (file-systems): Add 'file-system-label' call in 'device' field. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org> Laura Lazzati 2018-07-05doc: Improve UEFI/BIOS bootloader documentation....Partly fixes <https://bugs.gnu.org/30312>. * doc/guix.texi (Preparing for Installation): Add note on how to choose between UEFI and BIOS. (Using the Configuration System)[Bootloader]: New subsubsection. (Bootloader Configuration): Expound on the bootloader type and target. * gnu/system/examples/desktop.tmpl: Switch to UEFI. * gnu/system/examples/bare-bones.tmpl: Explicitly mention "legacy" and "BIOS" in the comments. Ludovic Courtès 2018-01-21doc: No longer mention Wicd in OS examples....* gnu/system/examples/desktop.tmpl, gnu/system/examples/lightweight-desktop.tmpl: Mention NetworkManager instead of Wicd. Ludovic Courtès 2017-08-23gnu: bootloader: Deprecate "device" field in favor of "target"....* gnu/bootloader.scm (<bootloader-configuration>): Deprecate "device" field in favor of "target" field. This is mostly a renaming but also a generalization to support UEFI targets being paths to a mounted partition instead of a device name. * gnu/system/examples/bare-bones.tmpl: * gnu/system/examples/desktop.tmpl: * gnu/system/examples/lightweight-desktop.tmpl: * gnu/system/examples/vm-image.tmpl: * gnu/system/install.scm: * gnu/tests.scm: * gnu/tests/install.scm: * gnu/tests/nfs.scm: * tests/system.scm: Adapt all invocations of bootloader-configuration. * guix/scripts/system.scm (perform-action): Rename device argument to bootloader-target. (process-action): Adapt caller. * doc/guix.texi (Proceeding with the Installation): * doc/guix.texi (Bootloader Configuration): Update documentation. Andy Wingo 2017-08-20gnu: grub-efi-bootloader: Specialize grub-install invocation....* gnu/bootloader/grub.scm (install-grub-efi): Fix grub-install invocation for EFI systems. * gnu/system/examples/bare-bones.tmpl: Use the newer "bootloader-configuration" syntax. * gnu/system/examples/desktop.tmpl: Use bootloader-configuration sytax. Also, use the same label for the LUKS-mapped device and the root partition. Remove unneeded "title" field for the file-system based on LUKS; as noted in the manual, the "title" field is ignored for mapped devices. * gnu/system/examples/lightweight-desktop.tmpl: Use bootloader-configuration, and use grub-efi-bootloader. Andy Wingo