aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:02:16 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:06:34 +0200
commit29c28811b934874defaf4c600e2addd6439476a7 (patch)
treec9f789cf3894eb06c2a4561fdd7e59ba344c2686
parent33d847e6ec568c8f3e2a8c3d95640b1556cce1dc (diff)
downloadguix-29c28811b934874defaf4c600e2addd6439476a7.tar.gz
guix-29c28811b934874defaf4c600e2addd6439476a7.zip
gnu: Add texlive-swfigure.
* gnu/packages/tex.scm (texlive-swfigure): New variable.
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index abba1ee0d3..53feb7325b 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -96918,6 +96918,27 @@ retrieve information necessary for the required output.")
typeset documents.")
(license license:lppl1.0+)))
+(define-public texlive-swfigure
+ (package
+ (name "texlive-swfigure")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/swfigure/"
+ "source/latex/swfigure/"
+ "tex/latex/swfigure/")
+ (base32
+ "1w2s9wil773dypa7xllbvawbdk41qdfzwy19pya17z8qp8csjqvh")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/swfigure")
+ (synopsis "Insert large images that do not fit into a single page")
+ (description
+ "This package defines five different display modes in order to place in
+a document large figures that do not fit into a single page. A single user
+macro is defined to handle all five display modes.")
+ (license license:lppl1.3c)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar