aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-26 14:43:41 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:17 +0200
commit290a006aaa420283a41fd2df42b59196b2103bbc (patch)
treea3a44e1af3256cddb78d70444f35abd3b8fe9039
parent35466639a0cc4450303826f8483318c0e24719d0 (diff)
downloadguix-290a006aaa420283a41fd2df42b59196b2103bbc.tar.gz
guix-290a006aaa420283a41fd2df42b59196b2103bbc.zip
gnu: Add texlive-lparse.
* gnu/packages/tex.scm (texlive-lparse): New variable.
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 58f4d9fd23..1f6f209940 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -16119,6 +16119,28 @@ reference mechanism. Line numbering may be extended to footnote lines, using
the @code{fnlineno} package.")
(license license:lppl1.3a+)))
+(define-public texlive-lparse
+ (package
+ (name "texlive-lparse")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/luatex/lparse/" "tex/luatex/lparse/")
+ (base32
+ "1m75w69qm67j82ja0lp38yckdsbn465aipzdbi2kg4y2xz34hli1")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/lparse")
+ (synopsis "Lua module for parsing key-value options")
+ (description
+ "@code{lparse} is derived from @code{xparse}, but only works with LuaTeX.
+Just as with xparse, it is possible to use a special syntax consisting of
+single letters to express the arguments of a macro. However, @code{lparse} is
+able to read arguments regardless of the macro systemd used -- whether LaTeX,
+or ConTeXt, or even plain TeX. Of course, LuaTeX must always be used as the
+engine.")
+ (license license:lppl1.3c)))
+
(define-public texlive-babel-czech
(package
(name "texlive-babel-czech")