aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:01:55 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:06:26 +0200
commit2817a6a7fe9764ce0cc3263c43f0f05b6ba3bfe1 (patch)
treeea1ab0f2f700e0ab28de1c33fd755ae67fe026c9
parent9c28a5cb38d3e88af178352559455ebcec003da2 (diff)
downloadguix-2817a6a7fe9764ce0cc3263c43f0f05b6ba3bfe1.tar.gz
guix-2817a6a7fe9764ce0cc3263c43f0f05b6ba3bfe1.zip
gnu: Add texlive-storecmd.
* gnu/packages/tex.scm (texlive-storecmd): New variable.
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c3240ed2f4..e93d5bc555 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -96524,6 +96524,26 @@ essentially turning it into a document format for mathematical knowledge
management (MKM).")
(license license:lppl)))
+(define-public texlive-storecmd
+ (package
+ (name "texlive-storecmd")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/storecmd/" "tex/latex/storecmd/")
+ (base32
+ "1ds88g5zb97vjlijnk2vq487ixs3pklq7f9fn66j17cdcnsz619f")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/storecmd")
+ (synopsis "Store the name of a defined command in a container")
+ (description
+ "The package provides macros for command definition that save the name of the
+command being defined in a file or a macro container. The list could be
+useful for spelling exceptions in text editors that do not support TeX
+syntax.")
+ (license license:lppl1.3+)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar