aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-05-08 00:29:08 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:43 +0000
commit273e52723965088bacfb86d5e5be3e1c3e62cc76 (patch)
tree32b5d0b76572acc202f53ab52d23fe66302d77f1
parent3cc911e6f03d5944363cf7bc6b0f9ca1b796d910 (diff)
downloadguix-273e52723965088bacfb86d5e5be3e1c3e62cc76.tar.gz
guix-273e52723965088bacfb86d5e5be3e1c3e62cc76.zip
gnu: Add python-jsonschema-path.
* gnu/packages/python-xyz.scm (python-jsonschema-path): New variable. Change-Id: Icda558659ea77f040eedb3e7f8605b50b3aaca37
-rw-r--r--gnu/packages/python-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f31324bdd0..baedf4f074 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6061,6 +6061,37 @@ and convert DDL to BigQuery JSON schema.")
(list python-setuptools-scm python-twisted
python-setuptools python-wheel))))
+(define-public python-jsonschema-path
+ (package
+ (name "python-jsonschema-path")
+ (version "0.3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "jsonschema_path" version))
+ (sha256
+ (base32 "129rb8y2bj2wwps8vs3z1qav006k7wz2myx5j6dnxqs1yfmsn3ad"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:tests? #false ;there are none
+ #:phases
+ '(modify-phases %standard-phases
+ (add-after 'unpack 'relax-requirements
+ (lambda _
+ (substitute* "pyproject.toml"
+ (("referencing = \">=0.28.0,<0.32.0\"")
+ "referencing = \">=0.28.0\"")))))))
+ (propagated-inputs (list python-pathable python-pyyaml python-referencing
+ python-requests))
+ (native-inputs (list python-poetry-core))
+ (home-page "https://github.com/p1c2u/jsonschema-path")
+ (synopsis "JSONSchema Spec with object-oriented paths")
+ (description "This package implements object-oriented JSONSchema. It lets
+you traverse a schema like paths and access a schema on demand with separate
+dereferencing accessor layer.")
+ (license license:asl2.0)))
+
(define-public python-jsonschema-specifications
(package
(name "python-jsonschema-specifications")