aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-22 11:48:46 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:52 +0000
commit2736e2018dd8e00db13f651b56925d48a94ba9e6 (patch)
tree40c170d848401e22548702a4bda31dd5821a42f3
parent427bb76c47619d663e90b7eeefd1118c2faeb66b (diff)
downloadguix-2736e2018dd8e00db13f651b56925d48a94ba9e6.tar.gz
guix-2736e2018dd8e00db13f651b56925d48a94ba9e6.zip
gnu: go-github-com-aead-chacha20: Update to 0.0.0-20180709150244-8b13a72661da.
* gnu/packages/golang-crypto.scm (go-github-com-aead-chacha20): Update to 0.0.0-20180709150244-8b13a72661da. Change-Id: I01b464ea6da2f89a3d4e4eeba2e2c13d1f3ac10b
-rw-r--r--gnu/packages/golang-crypto.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index d221f78596..0034017d3b 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -241,17 +241,15 @@ pcredential store, Pass, Secret Service, KDE Wallet, Encrypted File.")
(license license:expat)))
(define-public go-github-com-aead-chacha20
- (let ((commit "8b13a72661dae6e9e5dea04f344f0dc95ea29547")
- (revision "0"))
(package
(name "go-github-com-aead-chacha20")
- (version (git-version "0.0.0" revision commit))
+ (version "0.0.0-20180709150244-8b13a72661da")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/aead/chacha20")
- (commit commit)))
+ (commit (go-version->git-ref version))))
(file-name (git-file-name name version))
(sha256
(base32 "0gbmgq5kbqmbyrsav57ql4jzbvqvp1q7yvcd5fl3wf5g94iyv56r"))))
@@ -265,7 +263,7 @@ pcredential store, Pass, Secret Service, KDE Wallet, Encrypted File.")
(description "ChaCha is a stream cipher family created by Daniel
Bernstein. The most common ChaCha variant is ChaCha20 (20 rounds). ChaCha20
is standardized in RFC 7539.")
- (license license:expat))))
+ (license license:expat)))
(define-public go-github-com-aead-ecdh
(package