aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-15 23:53:05 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:28 +0200
commit270c474bd7f9d643c58eee62f2205faa17720aa1 (patch)
treed609be76b9931c582845a3414746159d572520e4
parent8787605c5ecb28b9ffa5eaa2f2f5fa998ccfd12a (diff)
downloadguix-270c474bd7f9d643c58eee62f2205faa17720aa1.tar.gz
guix-270c474bd7f9d643c58eee62f2205faa17720aa1.zip
gnu: Add texlive-chktex.
* gnu/packages/tex.scm (texlive-chktex): New variable.
-rw-r--r--gnu/packages/tex.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2121caad40..a42b123a63 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1347,6 +1347,34 @@ labels. It also looks for non starred mathematical environments with no
labels and advises the user to use a starred version instead.")
(license license:gpl3)))
+(define-public texlive-chktex
+ (package
+ (name "texlive-chktex")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "chktex/"
+ "doc/chktex/"
+ "doc/man/man1/chktex.1"
+ "doc/man/man1/chktex.man1.pdf"
+ "doc/man/man1/chkweb.1"
+ "doc/man/man1/chkweb.man1.pdf"
+ "doc/man/man1/deweb.1"
+ "doc/man/man1/deweb.man1.pdf"
+ "scripts/chktex/")
+ (base32
+ "0qyrllxvcymmr1a4sq9c88fw5zchcx0n6yac69s61fg6xypk18bq")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:link-scripts #~(list "chkweb.sh" "deweb.pl")))
+ (inputs (list perl))
+ (home-page "https://ctan.org/pkg/chktex")
+ (synopsis "Check for errors in LaTeX documents")
+ (description
+ "The program reports typographic and other errors in LaTeX documents.
+Filters are also provided for checking the LaTeX parts of CWEB documents.")
+ (license license:gpl2+)))
+
(define-public texlive-dvipsconfig
(package
(name "texlive-dvipsconfig")