aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-12-28 10:58:14 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-01 14:35:16 +0100
commit25d7dbd61c5420e105c36eef9b3583c87088bb40 (patch)
treeb61683e0af4c829c0c0a567d16c91ff0df595189
parent513994aead5a5da6cdec51931bc8b624c66678e1 (diff)
downloadguix-25d7dbd61c5420e105c36eef9b3583c87088bb40.tar.gz
guix-25d7dbd61c5420e105c36eef9b3583c87088bb40.zip
gnu: Add r-inext.
* gnu/packages/cran.scm (r-inext): New variable. Change-Id: I6a87cfb57bfc8000520b98999cf260d2873f0b61
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 86af55c070..19d1e7d043 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -7530,6 +7530,32 @@ experiments\" (2011), Annals of Applied Statistics, Vol. 5, No. 3, 1752-1779,
by Li, Brown, Huang, and Bickel")
(license license:gpl2+)))
+(define-public r-inext
+ (package
+ (name "r-inext")
+ (version "3.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "iNEXT" version))
+ (sha256
+ (base32 "1yfvadvdwgby047svj9sjwkm7hhrni2ifn6d2g5bv9djcvi22msh"))))
+ (properties `((upstream-name . "iNEXT")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-ggplot2 r-rcpp r-reshape2))
+ (native-inputs (list r-knitr))
+ (home-page "http://chao.stat.nthu.edu.tw/wordpress/software_download/")
+ (synopsis "Interpolation and extrapolation for species diversity")
+ (description
+ "This package provides simple functions to compute and plot two types
+(sample-size- and coverage-based) rarefaction and extrapolation curves for
+species diversity (Hill numbers) based on individual-based abundance data or
+sampling-unit- based incidence data; see Chao and others (2014, Ecological
+Monographs) for pertinent theory and methodologies, and Hsieh, Ma and Chao
+(2016, Methods in Ecology and Evolution) for an introduction of the R
+package.")
+ (license license:gpl3+)))
+
(define-public r-inline
(package
(name "r-inline")