aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@reproducible-builds.org>2025-03-01 13:51:45 -0800
committerVagrant Cascadian <vagrant@debian.org>2025-03-01 13:57:29 -0800
commit2558392803663f4381fa9c09a53d329b719152bd (patch)
treef200264df2731ce9bc0138bc0ac48e60322d7f7f
parent0dacce45462aa2adc9f5d43a4ff8cc158261f6a8 (diff)
downloadguix-2558392803663f4381fa9c09a53d329b719152bd.tar.gz
guix-2558392803663f4381fa9c09a53d329b719152bd.zip
gnu: reprotest: Add phase fixing executable bit on virt files.
The switch to pyproject-build-system in commit d3bad46f990fbd884ca114dddd5af0eae434aecc left off the execute bit on several files. Fixes: https://issues.guix.gnu.org/76602 * gnu/packages/diffoscope.scm (reprotest): Add 'make-virt-files-executable phase. Change-Id: Ie5e2b85b03aa11a1ede2d01069da2f401e2d424b
-rw-r--r--gnu/packages/diffoscope.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index d0e911363d..481fea49e7 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -273,6 +273,13 @@ install.")
#:tests? #f
#:phases
#~(modify-phases %standard-phases
+ (add-after 'compress-documentation 'make-virt-files-executable
+ ;; The autopkgtest-virt- files need to be marked executable for
+ ;; reprotest to function correctly.
+ (lambda _
+ (for-each (lambda (file)
+ (chmod file #o755))
+ (find-files #$output "autopkgtest-virt-.*"))))
(add-after 'install 'install-doc
(lambda _
(let* ((mandir1 (string-append