aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2025-01-02 09:59:32 +0200
committerEfraim Flashner <efraim@flashner.co.il>2025-01-02 18:45:05 +0200
commit246ac968a2c20003035de50993a364908aadc4d0 (patch)
treeb5f34a34a2b9be02f276f18b13e5e7691617bb61
parent20089e244902717eafd5b90ab76ef0704ba1695f (diff)
downloadguix-246ac968a2c20003035de50993a364908aadc4d0.tar.gz
guix-246ac968a2c20003035de50993a364908aadc4d0.zip
gnu: lagrange: Correctly link with libunistring.
* gnu/packages/web-browsers.scm (lagrange)[arguments]: Adjust 'configure-flags to set the location of libunistring. Change-Id: I62b9ca0a7d11b51e7699833d645fec8cbc428179
-rw-r--r--gnu/packages/web-browsers.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 293419fb46..d035e19476 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 John Darrington <jmd@gnu.org>
;;; Copyright © 2014, 2019 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2015, 2016, 2019, 2021-2023 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015, 2016, 2019, 2021-2023, 2025 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2017, 2024 Eric Bavier <bavier@posteo.net>
;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -750,8 +750,12 @@ is fully configurable and extensible in Common Lisp.")
(delete-file-recursively "lib/sealcurses")))))
(build-system cmake-build-system)
(arguments
- `(#:tests? #false ;no tests
- #:configure-flags (list "-DTFDN_ENABLE_SSE41=OFF")))
+ (list
+ #:tests? #false ;no tests
+ #:configure-flags
+ #~(list "-DTFDN_ENABLE_SSE41=OFF"
+ (string-append "-DUNISTRING_DIR="
+ #$(this-package-input "libunistring")))))
(native-inputs
(list pkg-config zip))
(inputs