aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-15 21:56:58 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:40 +0200
commit238b1c4db6b96a33a1d7ecc980f1b8a3108d37b1 (patch)
treeae5e918c6da7adcd599d8f4fb134c28aca941292
parent492b7903a90fe60b62d3ea06ba3581f04028a9be (diff)
downloadguix-238b1c4db6b96a33a1d7ecc980f1b8a3108d37b1.tar.gz
guix-238b1c4db6b96a33a1d7ecc980f1b8a3108d37b1.zip
gnu: texlive-marvosym: Refresh package definition.
* gnu/packages/tex.scm (texlive-marvosym): Remove SIMPLE-TEXLIVE-PACKAGE call.
-rw-r--r--gnu/packages/tex.scm44
1 files changed, 24 insertions, 20 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 1f8b4be9df..fe2775e8b2 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -8422,27 +8422,31 @@ OT2 encoded fonts, CM bright shaped fonts and Concrete shaped fonts.")
(define-public texlive-marvosym
(package
- (inherit (simple-texlive-package
- "texlive-marvosym"
- (list "/doc/fonts/marvosym/"
- "/fonts/afm/public/marvosym/"
- "/fonts/map/dvips/marvosym/"
- "/fonts/tfm/public/marvosym/"
- "/fonts/truetype/public/marvosym/"
- "/fonts/type1/public/marvosym/"
- "/tex/latex/marvosym/")
- (base32
- "0m3bbg06cia8ni86fjhvb7x4a5qcxgnpqcvicfms91w2px9ysc46")
- #:trivial? #t))
- (home-page "https://martinvogel.de/blog/index.php?\
-/archives/131-Marvosym.ttf.html")
+ (name "texlive-marvosym")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/fonts/marvosym/"
+ "fonts/afm/public/marvosym/"
+ "fonts/map/dvips/marvosym/"
+ "fonts/tfm/public/marvosym/"
+ "fonts/truetype/public/marvosym/"
+ "fonts/type1/public/marvosym/"
+ "source/fonts/marvosym/"
+ "tex/latex/marvosym/")
+ (base32
+ "16s5ibpw6c9d3vzc82hfn90dg643xlracivikdbr9s43f2ayak41")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/marvosym")
(synopsis "Martin Vogel's Symbols (marvosym) font")
- (description "The Martin Vogel’s Symbols fonts (marvosym) contains the
-Euro currency symbol as defined by the European commission, along with symbols
-for structural engineering, symbols for steel cross-sections, astronomy
-signs (sun, moon, planets), the 12 signs of the zodiac, scissor symbols, CE
-sign and others. This package contains both the original TrueType font and
-the derived Type 1 font, together with support files for TeX (LaTeX).")
+ (description
+ "Martin Vogel's Symbol font (marvosym) contains the Euro currency symbol
+as defined by the European commission, along with symbols for structural
+engineering; symbols for steel cross-sections; astronomy signs (sun, moon,
+planets); the 12 signs of the zodiac; scissor symbols; CE sign and others.
+The package contains both the original TrueType font and the derived Type
+1 font, together with support files for TeX (LaTeX).")
(license (list license:lppl ;for TeX support files
license:silofl1.1)))) ;for fonts