aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-05-10 11:40:13 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:46 +0000
commit237cf5c231e0c2cc5d2b6a3f5ef96279b9e82002 (patch)
tree97d79d47ca4f60b44154f49f7f1cb0397a963638
parent737e09e4d24fecf623633b057ef59e4c4e2c4483 (diff)
downloadguix-237cf5c231e0c2cc5d2b6a3f5ef96279b9e82002.tar.gz
guix-237cf5c231e0c2cc5d2b6a3f5ef96279b9e82002.zip
gnu: Add python-comm.
* gnu/packages/jupyter.scm (python-comm): New variable. Change-Id: I888125238a566b470d4f5f96c5cc178f41a7a4ff
-rw-r--r--gnu/packages/jupyter.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/jupyter.scm b/gnu/packages/jupyter.scm
index f86b59489a..01c5f617f9 100644
--- a/gnu/packages/jupyter.scm
+++ b/gnu/packages/jupyter.scm
@@ -53,6 +53,32 @@
#:use-module (gnu packages serialization)
#:use-module (gnu packages version-control))
+(define-public python-comm
+ (package
+ (name "python-comm")
+ (version "0.2.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ipython/comm")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "18xsbpd8dgcfbc51xl59nlwaq7jnyzvgzjfj6psscv71894x4lg7"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-traitlets))
+ (native-inputs
+ (list python-hatchling
+ python-pytest))
+ (home-page "https://github.com/ipython/comm")
+ (synopsis "Jupyter Python Comm implementation")
+ (description
+ "Jupyter Python Comm provides a way to register a Kernel Comm
+implementation, as per the Jupyter kernel protocol. It also provides a base
+Comm implementation and a default CommManager that can be used.")
+ (license license:bsd-3)))
+
(define-public python-nbclassic
(package
(name "python-nbclassic")