aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2024-08-18 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2024-08-18 02:00:00 +0200
commit227ada19779590d58057d371e71a623ef28ef073 (patch)
treed7a83cfeb008e40a27ea3e3f7a5d3ce5f924ffe3
parentfce803005868f6d0568ba1b90a33d8eb8a8b5aa1 (diff)
downloadguix-227ada19779590d58057d371e71a623ef28ef073.tar.gz
guix-227ada19779590d58057d371e71a623ef28ef073.zip
gnu: oath-toolkit: Update to 2.6.11.
* gnu/packages/authentication.scm (oath-toolkit): Update to 2.6.11. [arguments]: Don't explicitly return #t from phases. Change-Id: I3cc1455690ed6a2bd8dc43c2b18fa60fcb4443a9
-rw-r--r--gnu/packages/authentication.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/authentication.scm b/gnu/packages/authentication.scm
index 7c7fb8e861..da778de4cb 100644
--- a/gnu/packages/authentication.scm
+++ b/gnu/packages/authentication.scm
@@ -62,14 +62,14 @@
(define-public oath-toolkit
(package
(name "oath-toolkit")
- (version "2.6.9")
+ (version "2.6.11")
(source
(origin
(method url-fetch)
(uri (string-append "https://download.savannah.nongnu.org/releases/"
name "/" name "-" version ".tar.gz"))
(sha256
- (base32 "11g9r1avl3d2nnkglk0g7d6z6gs5padk75xqzvbxp9pir0qwhfik"))))
+ (base32 "1d1c3r1jhd72l5ppsfa9wvvm8kffzs4k2v2qn0xc9x26bd52llgw"))))
(build-system gnu-build-system)
(arguments
;; TODO ‘--enable-pskc’ causes xmlsec-related test suite failures.
@@ -83,8 +83,7 @@
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(lib (string-append out "/lib")))
- (for-each delete-file (find-files lib "\\.a$"))
- #t))))))
+ (for-each delete-file (find-files lib "\\.a$"))))))))
(native-inputs
(list pkg-config
;; XXX: Perhaps this should be propagated from xmlsec.