aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2024-11-26 09:32:44 +0100
committerLudovic Courtès <ludo@gnu.org>2024-12-01 20:14:15 +0100
commit2227a6b0846f7228d3f9ef7fca2f92c1a48bf11d (patch)
treeaca9d55a8fdfd79089781d76650c7a45c3bb6025
parente85cce3431a0d04e9dedbabd4c24c451bb13001e (diff)
downloadguix-2227a6b0846f7228d3f9ef7fca2f92c1a48bf11d.tar.gz
guix-2227a6b0846f7228d3f9ef7fca2f92c1a48bf11d.zip
gnu: Update updater properties for GnuPG-related packages.
* gnu/packages/gnupg.scm (libgpg-error)[properties]: Remove. (libgcrypt)[properties]: Remove. (libassuan)[properties]: Remove. (libksba)[properties]: Remove. (npth)[properties]: Remove. (gnupg)[properties]: Remove. (gpgme)[properties]: Remove. (pinentry-tty)[properties]: Change for ‘generic-html’. (gpa)[properties]: Remove. Change-Id: I1eb9d6ad5bb3ecbfbef3d44dbae281a3de7ebac7
-rw-r--r--gnu/packages/gnupg.scm40
1 files changed, 12 insertions, 28 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 2e97c2244a..3f55ccaf5b 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012-2021, 2023 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012-2021, 2023, 2024 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013, 2015, 2018 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014, 2018 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2014, 2015, 2016, 2020 Mark H Weaver <mhw@netris.org>
@@ -160,9 +160,7 @@
for all GnuPG components. Among these are GPG, GPGSM, GPGME,
GPG-Agent, libgcrypt, Libksba, DirMngr, Pinentry, SmartCard
Daemon and possibly more in the future.")
- (license license:lgpl2.0+)
- (properties '((ftp-server . "ftp.gnupg.org")
- (ftp-directory . "/gcrypt/libgpg-error")))))
+ (license license:lgpl2.0+)))
(define-public libgcrypt
(package
@@ -217,9 +215,7 @@ Daemon and possibly more in the future.")
standard cryptographic building blocks such as symmetric ciphers, hash
algorithms, public key algorithms, large integer functions and random number
generation.")
- (license license:lgpl2.0+)
- (properties '((ftp-server . "ftp.gnupg.org")
- (ftp-directory . "/gcrypt/libgcrypt")))))
+ (license license:lgpl2.0+)))
(define-public libassuan
(package
@@ -250,9 +246,7 @@ generation.")
protocol. This protocol is used for IPC between most newer
GnuPG components. Both, server and client side functions are
provided.")
- (license license:lgpl2.0+)
- (properties '((ftp-server . "ftp.gnupg.org")
- (ftp-directory . "/gcrypt/libassuan")))))
+ (license license:lgpl2.0+)))
(define-public libksba
(package
@@ -283,9 +277,7 @@ provided.")
"KSBA (pronounced Kasbah) is a library to make X.509 certificates
as well as the CMS easily accessible by other applications. Both
specifications are building blocks of S/MIME and TLS.")
- (license license:gpl3+)
- (properties '((ftp-server . "ftp.gnupg.org")
- (ftp-directory . "/gcrypt/libksba")))))
+ (license license:gpl3+)))
(define-public npth
(package
@@ -307,9 +299,7 @@ threads implementation.
In contrast to GNU Pth is is based on the system's standard threads
implementation. This allows the use of libraries which are not
compatible to GNU Pth.")
- (license (list license:lgpl3+ license:gpl2+)) ; dual license
- (properties '((ftp-server . "ftp.gnupg.org")
- (ftp-directory . "/gcrypt/npth")))))
+ (license (list license:lgpl3+ license:gpl2+)))) ;dual license
(define-public gnupg
(package
@@ -404,9 +394,7 @@ features powerful key management and the ability to access public key
servers. It includes several libraries: libassuan (IPC between GnuPG
components), libgpg-error (centralized GnuPG error values), and
libskba (working with X.509 certificates and CMS data).")
- (license license:gpl3+)
- (properties '((ftp-server . "ftp.gnupg.org")
- (ftp-directory . "/gcrypt/gnupg")))))
+ (license license:gpl3+)))
(define-public gnupg-1
(package (inherit gnupg)
@@ -463,9 +451,7 @@ Because the direct use of GnuPG from an application can be a complicated
programming task, it is suggested that all software should try to use GPGME
instead. This way bug fixes or improvements can be done at a central place
and every application benefits from this.")
- (license license:lgpl2.1+)
- (properties '((ftp-server . "ftp.gnupg.org")
- (ftp-directory . "/gcrypt/gpgme")))))
+ (license license:lgpl2.1+)))
(define-public gpgme-1.23
(hidden-package
@@ -886,9 +872,9 @@ including tools for signing keys, keyring analysis, and party preparation.
"Pinentry provides a console that allows users to enter a passphrase when
@code{gpg} is run and needs it.")
(license license:gpl2+)
- (properties '((ftp-server . "ftp.gnupg.org")
- (ftp-directory . "/gcrypt/pinentry")
- (upstream-name . "pinentry")))))
+ (properties
+ '((release-monitoring-url . "https://gnupg.org/ftp/gcrypt/pinentry/")
+ (upstream-name . "pinentry")))))
(define-public pinentry-emacs
(package
@@ -1134,9 +1120,7 @@ however, pgpdump produces more detailed and easier to understand output.")
"GPA, the GNU Privacy Assistant, is a graphical user interface for
@uref{https://gnupg.org, GnuPG}. It can be used to encrypt, decrypt, and sign
files, to verify signatures, and to manage the private and public keys.")
- (license license:gpl3+)
- (properties '((ftp-server . "ftp.gnupg.org")
- (ftp-directory . "/gcrypt/gpa")))))
+ (license license:gpl3+)))
(define-public parcimonie
(package