aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDariqq <dariqq@posteo.net>2024-06-26 15:43:32 +0000
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:45:19 +0200
commit220546810830422f8ec3e6a4145fec85429914a1 (patch)
treec1fc403228ca5936fd7a579e6054c7cbc0438d4d
parentf548a7b5862b56ce7b4c89771269cfba390f2545 (diff)
downloadguix-220546810830422f8ec3e6a4145fec85429914a1.tar.gz
guix-220546810830422f8ec3e6a4145fec85429914a1.zip
build-system/meson: Add #:out-of-source? argument to build system.
Meson currently supports only out-of-source builds. Add the argument out-of-source? with default to #t such that the install-license-files phase searches for the license files in the source directory. * guix/build-system/meson.scm (meson-build): Add out-of-source? argument. (meson-cross-build): Likewise. Change-Id: Ib59d9d93b34fd567f05f5f9a10293f6ab924e399 Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--guix/build-system/meson.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/guix/build-system/meson.scm b/guix/build-system/meson.scm
index 13baf329df..eb2714dd78 100644
--- a/guix/build-system/meson.scm
+++ b/guix/build-system/meson.scm
@@ -188,6 +188,7 @@ TRIPLET."
(outputs '("out"))
(configure-flags ''())
(search-paths '())
+ (out-of-source? #t)
(build-type "debugoptimized")
(tests? #t)
(test-options ''())
@@ -237,6 +238,7 @@ has a 'meson.build' file."
#$(if (pair? configure-flags)
(sexp->gexp configure-flags)
configure-flags)
+ #:out-of-source? #$out-of-source?
#:build-type #$build-type
#:tests? #$tests?
#:test-options #$(if (pair? test-options)
@@ -271,7 +273,7 @@ has a 'meson.build' file."
(configure-flags ''())
(search-paths '())
(native-search-paths '())
-
+ (out-of-source? #t)
(build-type "debugoptimized")
(tests? #f)
(test-options ''())
@@ -352,6 +354,7 @@ SOURCE has a 'meson.build' file."
,@#$(if (pair? configure-flags)
(sexp->gexp configure-flags)
configure-flags))
+ #:out-of-source? #$out-of-source?
#:build-type #$build-type
#:tests? #$tests?
#:test-options #$(if (pair? test-options)