aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2025-01-09 22:38:03 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2025-03-02 20:31:41 +0100
commit218438e2d6fd6e8ded182adf7645e125b6d4d46f (patch)
tree2572699ef0a3ebbafb78d46bc503f4d11553325f
parent93753cbb18f98831c1997730b60c70532780b8dd (diff)
downloadguix-218438e2d6fd6e8ded182adf7645e125b6d4d46f.tar.gz
guix-218438e2d6fd6e8ded182adf7645e125b6d4d46f.zip
gnu: feedbackd: Update to 0.6.0.
* gnu/packages/gnome.scm (feedbackd): Update to 0.6.0. [source]: Drop patches. [#:phases]: Add ‘fix-meson’ [native-inputs]: Add umockdev. * gnu/packages/patches/feedbackd-use-system-gmobile.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it from here.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/gnome.scm16
-rw-r--r--gnu/packages/patches/feedbackd-use-system-gmobile.patch42
3 files changed, 11 insertions, 48 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index b397d1aa36..326875133f 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1278,7 +1278,6 @@ dist_patch_DATA = \
%D%/packages/patches/fbgemm-use-system-libraries.patch \
%D%/packages/patches/fbreader-curl-7.62.patch \
%D%/packages/patches/fbreader-fix-icon.patch \
- %D%/packages/patches/feedbackd-use-system-gmobile.patch \
%D%/packages/patches/fenics-dolfin-algorithm.patch \
%D%/packages/patches/fenics-dolfin-demo-init.patch \
%D%/packages/patches/fenics-dolfin-boost.patch \
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index f75084dbb3..5dde0dc1c1 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -13570,7 +13570,7 @@ host to avoid parser overhead and memory-allocator fragmentation.")
(define-public feedbackd
(package
(name "feedbackd")
- (version "0.2.1")
+ (version "0.6.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -13579,16 +13579,22 @@ host to avoid parser overhead and memory-allocator fragmentation.")
(file-name (git-file-name name version))
(sha256
(base32
- "1acwpb8cgzyvzriphrb42k3d7njwcn88j66i5wz75yx2sbfaf93q"))
- (patches
- (search-patches "feedbackd-use-system-gmobile.patch"))
+ "0gfh965rddmg9glyh0gzkzxi27c7kfdakwrkycc7hg7s68p03xgh"))
(snippet
#~(begin
(use-modules (guix build utils))
(delete-file-recursively "subprojects")))))
(build-system meson-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-meson
+ (lambda _
+ (substitute* "meson.build"
+ (("udev.get_variable\\('udevdir'\\)")
+ "prefix / 'lib' / 'udev'")))))))
(native-inputs
- (list `(,glib "bin") gobject-introspection pkg-config vala))
+ (list `(,glib "bin") gobject-introspection pkg-config umockdev vala))
(inputs
(list dbus gmobile gsound json-glib libgudev))
(propagated-inputs
diff --git a/gnu/packages/patches/feedbackd-use-system-gmobile.patch b/gnu/packages/patches/feedbackd-use-system-gmobile.patch
deleted file mode 100644
index f0a0449472..0000000000
--- a/gnu/packages/patches/feedbackd-use-system-gmobile.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From af9e72124b12ca481fd3592f9c8ea2649f7e4c80 Mon Sep 17 00:00:00 2001
-Message-ID: <af9e72124b12ca481fd3592f9c8ea2649f7e4c80.1698775513.git.vivien@planete-kraus.eu>
-From: Vivien Kraus <vivien@planete-kraus.eu>
-Date: Sun, 29 Oct 2023 19:12:27 +0100
-Subject: [PATCH] Look for a system-installed gmobile first.
-
-Meson lets projects use a dependency with fallback to a submodule, in
-case the dependency is not installed.
-
-* meson.build (gmobile_subp): Convert to a dependency with subproject
-fallback.
----
-I am waiting for Purism to approve my account before I can report this.
-
- meson.build | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/meson.build b/meson.build
-index 8725e76..e5504be 100644
---- a/meson.build
-+++ b/meson.build
-@@ -14,13 +14,13 @@ gio_unix = dependency('gio-unix-2.0', version: '>=2.50.0')
- glib = dependency('glib-2.0', version: '>=2.50.0')
- if get_option('daemon')
- gobject = dependency('gobject-2.0', version: '>=2.50.0')
-- gmobile_subp = subproject('gmobile',
-+ gmobile = dependency('gmobile',
-+ fallback: ['gmobile', 'gmobile_dep'],
- default_options: [
- 'examples=false',
- 'gtk_doc=false',
- 'tests=false',
- ])
-- gmobile = gmobile_subp.get_variable('gmobile_dep')
- gsound = dependency('gsound')
- gudev = dependency('gudev-1.0', version: '>=232')
- json_glib = dependency('json-glib-1.0')
-
-base-commit: 853bd6d7ea8455efea063ba7c4f29ce8c203285f
---
-2.41.0
-