aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-11-28 23:48:56 +0000
committerArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-12-01 10:27:37 +0300
commit215ae40b5d953a98b4c71f772c515adf5ad8ddf5 (patch)
tree0798f27b9dbf83f74331c004c4e66eaf335a197c
parent58344dfb0ec1972946f1a9f38880e2875287fad6 (diff)
downloadguix-215ae40b5d953a98b4c71f772c515adf5ad8ddf5.tar.gz
guix-215ae40b5d953a98b4c71f772c515adf5ad8ddf5.zip
gnu: Add go-github-com-aymanbagabas-go-udiff.
* gnu/packages/golang-xyz.scm (go-github-com-aymanbagabas-go-udiff): New variable. Change-Id: Icac934589b041c9b3b5db0114173d25d0c3f4c34 Reviewed-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/golang-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index daafc1285c..913b741871 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1159,6 +1159,34 @@ strategies, such as fixed delay, backoff delay, and random delay.")
clipboard.")
(license license:expat)))
+(define-public go-github-com-aymanbagabas-go-udiff
+ (package
+ (name "go-github-com-aymanbagabas-go-udiff")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/aymanbagabas/go-udiff")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "09p17r8s5flhq6p69z08345q0y99dpb0yyashlwpgxn45xir7y6g"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/aymanbagabas/go-udiff"))
+ (home-page "https://github.com/aymanbagabas/go-udiff")
+ (synopsis "Diffing library for Golang")
+ (description
+ "@code{udiff} (micro-diff, or µDiff) is a library that implements the
+@url{http://www.xmailserver.org/diff2.pdf, Myers' diffing algorithm}. It aims to
+provide a minimal API to compute and apply diffs with zero dependencies. It also
+supports generating diffs in the
+@url{https://www.gnu.org/software/diffutils/manual/html_node/Unified-Format.html,
+Unified Format}.")
+ (license license:expat)))
+
(define-public go-github-com-benbjohnson-clock
(package
(name "go-github-com-benbjohnson-clock")