aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2023-05-01 21:52:48 +0800
committer宋文武 <iyzsong@member.fsf.org>2023-05-01 21:52:48 +0800
commit1fc66b9db148413c7baccf1a74c4a778ba86bbc5 (patch)
treea64e0abd8faf2e26ad0e4e3efdc3db4898102182
parent0c6a7e1045cbd06336ef3699734a803a2e4038e5 (diff)
downloadguix-1fc66b9db148413c7baccf1a74c4a778ba86bbc5.tar.gz
guix-1fc66b9db148413c7baccf1a74c4a778ba86bbc5.zip
gnu: catfish: Fix build.
* gnu/packages/xfce.scm (catfish)[arguments]: Disable the sanity-check phase.
-rw-r--r--gnu/packages/xfce.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 43da524b44..19be07bd79 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -243,6 +243,8 @@ to share commonly used Xfce widgets among the Xfce applications.")
(invoke "python" "setup.py" "install"
(string-append "--prefix=" (assoc-ref outputs "out"))
"--root=/")))
+ ;; The check failed to spawn a message bus without /etc/machine-id.
+ (delete 'sanity-check)
(add-after 'install 'wrap-program
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))