aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-12-02 09:43:25 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-12-02 10:28:59 +0100
commit1f047996b8d5f1e8f40e611922fa4ca1c20b0104 (patch)
treeb4a0cc0aa0fad39ab0d5f3417d90b0a2a5466e67
parented1266ea8c1ef7bc8a18959a21b63c0ec0ae9b50 (diff)
downloadguix-1f047996b8d5f1e8f40e611922fa4ca1c20b0104.tar.gz
guix-1f047996b8d5f1e8f40e611922fa4ca1c20b0104.zip
gnu: python-hmmlearn: Update to 0.3.3.
* gnu/packages/machine-learning.scm (python-hmmlearn): Update to 0.3.3. [build-system]: Use pyproject-build-system. [arguments]: Remove custom 'check phase; add phases 'set-core-count and 'build-extensions. [propagated-inputs]: Remove pybind11 and python-setuptools-scm. [native-inputs]: Add pybind11, python-setuptools-scm, and util-linux. [properties]: Add hints for the updater. Change-Id: I1acb69c74ae9c4a508fe28cdaf834d258e7778ff
-rw-r--r--gnu/packages/machine-learning.scm32
1 files changed, 17 insertions, 15 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 3696a81ea6..9b3813e8df 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -5422,32 +5422,34 @@ Python.")
(define-public python-hmmlearn
(package
(name "python-hmmlearn")
- (version "0.2.8")
+ (version "0.3.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "hmmlearn" version))
(sha256
(base32
- "1yd5l9ra37mks41mn5bigav7xpb161a9yqlcnz4ir076vkik2sb9"))))
- (build-system python-build-system)
+ "1v24rkqjjf67w2rys25qxa3vk30bf23m7zn1ilihqzi5qp25sg0x"))))
+ (properties
+ '((updater-extra-native-inputs . ("pybind11" "python-setuptools-scm"))))
+ (build-system pyproject-build-system)
(arguments
(list
#:phases
- #~(modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (with-directory-excursion (string-append #$output "/lib")
- (invoke "python" "-m" "pytest"))))))))
+ '(modify-phases %standard-phases
+ (add-after 'unpack 'set-core-count
+ (lambda _
+ ;; "Could not find the number of physical cores", so we tell it
+ ;; how many cores to use.
+ (setenv "LOKY_MAX_CPU_COUNT" "1")))
+ (add-before 'check 'build-extensions
+ (lambda _
+ (invoke "python" "setup.py" "build_ext" "--inplace"))))))
(propagated-inputs
- (list pybind11
- python-numpy
- python-scikit-learn
- python-scipy
- python-setuptools-scm))
+ (list python-numpy python-scikit-learn python-scipy))
(native-inputs
- (list python-pytest))
+ (list pybind11 python-pytest python-setuptools-scm
+ util-linux)) ;for lscpu
(home-page "https://github.com/hmmlearn/hmmlearn")
(synopsis "Hidden Markov Models with scikit-learn like API")
(description