diff options
author | Janneke Nieuwenhuizen <janneke@gnu.org> | 2024-01-24 17:13:23 +0100 |
---|---|---|
committer | Ludovic Courtès <ludo@gnu.org> | 2024-08-31 10:44:43 +0200 |
commit | 1cf91238a2b06a472faa43bd6324e705dfd9b8a5 (patch) | |
tree | 08f9144ee6a1afb65abc7ce3b22051879daf259c | |
parent | 8ff0ee8ed6deef04d5706a7f243e7c0248a2e25b (diff) | |
download | guix-1cf91238a2b06a472faa43bd6324e705dfd9b8a5.tar.gz guix-1cf91238a2b06a472faa43bd6324e705dfd9b8a5.zip |
gnu: python-pyelftools: Update to 0.30 [fixes build].
This avoids
Test file 'test/testfiles_for_readelf/aarch64-relocs-le.o.elf'
.......................FAIL
....for file test/testfiles_for_readelf/aarch64-relocs-le.o.elf
....for option "--debug-dump=info"
....Output #1 is readelf, Output #2 is pyelftools
@@ Mismatch on line #1:
>> compilation unit @ offset 0:<<
>> compilation unit @ offset 0x0:<<
([('equal', 0, 29, 0, 29), ('insert', 29, 29, 29, 31), ('equal', 29, 30, 31, 32)])
* gnu/packages/python-xyz.scm (python-pyelftools): Update to 0.30.
[description]: Remove gratuitous whitespace.
Change-Id: I6e15e4532affd7faa7272d42adb65a2efcccce46
-rw-r--r-- | gnu/packages/python-xyz.scm | 12 |
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm index 2d14f47528..2b64a81024 100644 --- a/gnu/packages/python-xyz.scm +++ b/gnu/packages/python-xyz.scm @@ -144,7 +144,7 @@ ;;; Copyright © 2023 Parnikkapore <poomklao@yahoo.com> ;;; Copyright © 2023 Foundation Devices, Inc. <hello@foundationdevices.com> ;;; Copyright © c4droid <c4droid@foxmail.com> -;;; Copyright © 2023 Janneke Nieuwenhuizen <janneke@gnu.org> +;;; Copyright © 2023, 2024 Janneke Nieuwenhuizen <janneke@gnu.org> ;;; Copyright © 2023 Attila Lendvai <attila@lendvai.name> ;;; Copyright © 2023, 2024 Troy Figiel <troy@troyfigiel.com> ;;; Copyright © 2024 Timothee Mathieu <timothee.mathieu@inria.fr> @@ -23107,7 +23107,7 @@ OpenSSH Server for example.") (define-public python-pyelftools (package (name "python-pyelftools") - (version "0.29") + (version "0.30") (home-page "https://github.com/eliben/pyelftools") (source (origin @@ -23116,7 +23116,7 @@ OpenSSH Server for example.") (commit (string-append "v" version)))) (file-name (git-file-name name version)) (sha256 - (base32 "1mi7i9zlhkkap4q50ciak57ia46mj2jzq0713m3dh0x8j05k9xml")) + (base32 "0gk47mq5cqv6qz35aydn67wma5m70gv5f9f6pg38zny6vsfavmq3")) (snippet ;; Delete bundled readelf executable. '(delete-file "test/external_tools/readelf")))) @@ -23133,9 +23133,9 @@ OpenSSH Server for example.") (synopsis "Analyze binary and library file information") (description "This Python library provides interfaces for parsing and - analyzing two binary and library file formats ; the Executable and Linking - Format (ELF), and debugging information in the Debugging With Attributed - Record Format (DWARF).") +analyzing two binary and library file formats ; the Executable and Linking +Format (ELF), and debugging information in the Debugging With Attributed +Record Format (DWARF).") (license license:public-domain))) (define-public python-pefile |