aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-10 00:53:07 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:48 +0000
commit1c9a62192e50b44ab69f53e08148060be07d345a (patch)
tree660ba7e6f2109bdc4563161298e16c125acb78d1
parent2139b3724d7f8641c67cebc9671ce2f265f9c4e5 (diff)
downloadguix-1c9a62192e50b44ab69f53e08148060be07d345a.tar.gz
guix-1c9a62192e50b44ab69f53e08148060be07d345a.zip
gnu: python-docker-pycreds: Move to pyproject-build-system.
* gnu/packages/docker.scm (python-docker-pycreds): [build-system]: Move to pyproject-build-system. [arguments]<#:test-flags>: Use it. <#:phases>: Remove uneeded field. [native-inputs]: Remove python-pytest-cov and python-flake8. Add python-setuptools, python-wheel. Change-Id: Idde93a366fa187d2af915ed15801da2cdbaa3792 Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/docker.scm18
1 files changed, 7 insertions, 11 deletions
diff --git a/gnu/packages/docker.scm b/gnu/packages/docker.scm
index b49dc58bd0..0abe85f01e 100644
--- a/gnu/packages/docker.scm
+++ b/gnu/packages/docker.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2020 Jesse Dowell <jessedowell@gmail.com>
;;; Copyright © 2021, 2022 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2022 Pierre Langlois <pierre.langlois@gmx.com>
+;;; Copyright © 2024 Nicolas Graves <ngraves@ngraves.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -35,6 +36,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system go)
#:use-module (guix build-system python)
+ #:use-module (guix build-system pyproject)
#:use-module (guix utils)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
@@ -47,6 +49,7 @@
#:use-module (gnu packages networking)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-build)
#:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
@@ -151,19 +154,12 @@ created and all the services are started as specified in the configuration.")
(sha256
(base32
"1m44smrggnqghxkqfl7vhapdw89m1p3vdr177r6cq17lr85jgqvc"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-versioning
- (lambda _
- (substitute* "test-requirements.txt"
- (("3.0.2") ,(package-version python-pytest))
- (("2.3.1") ,(package-version python-pytest-cov))
- (("2.4.1") ,(package-version python-flake8)))
- #t)))))
+ (list ; XXX: These tests require docker credentials to run.
+ #:test-flags '(list "--ignore=tests/store_test.py")))
(native-inputs
- (list python-flake8 python-pytest python-pytest-cov))
+ (list python-pytest python-setuptools python-wheel))
(propagated-inputs
(list python-six))
(home-page "https://github.com/shin-/dockerpy-creds")