aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJake Leporte <jakeleporte@outlook.com>2023-02-20 10:13:06 -0600
committerLudovic Courtès <ludo@gnu.org>2023-02-25 00:00:33 +0100
commit1c13606a289b9ca97cf6aee2fddc14360b348ef3 (patch)
tree4f4d81740a185c696f28988c1d2106f914051cb1
parentff98a9f75a3e81ebea2cf576d85737db81f61fb0 (diff)
downloadguix-1c13606a289b9ca97cf6aee2fddc14360b348ef3.tar.gz
guix-1c13606a289b9ca97cf6aee2fddc14360b348ef3.zip
gnu: python-paste: Update to 3.5.2.
* gnu/packages/python-web.scm (python-paste): Update to 3.5.2. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-web.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 8c5b185e3f..8a73c929a1 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4599,23 +4599,23 @@ available in Django, but is a standalone package.")
(define-public python-paste
(package
(name "python-paste")
- (version "3.0.6")
+ (version "3.5.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Paste" version))
(sha256
(base32
- "14lbi9asn5agsdf7r97prkjpz7amgmp529lbvfhf0nv881xczah6"))
+ "1xjakxrdvy4kgfy170gb9bl8zp9hqjjwh1h1vlik1pxw606399ym"))
(patches (search-patches "python-paste-remove-timing-test.patch"))
(modules '((guix build utils)))
(snippet
'(begin
;; This test calls out to the internet.
(delete-file "tests/test_proxy.py") #t))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(native-inputs
- (list python-pytest python-pytest-runner python-nose))
+ (list python-pytest python-nose))
(propagated-inputs
(list python-six))
(home-page "https://pythonpaste.readthedocs.io/")