aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-22 16:52:54 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:23:29 +0000
commit1a31a9fa1ce99f5706f81772cbd4be0e496b9501 (patch)
treee23d23a600ce4ce45ce3fa89ef63861887f03bc6
parent860f7ad11b60d553219d03cab1a4675410a9633d (diff)
downloadguix-1a31a9fa1ce99f5706f81772cbd4be0e496b9501.tar.gz
guix-1a31a9fa1ce99f5706f81772cbd4be0e496b9501.zip
gnu: python-asttokens: Update to 2.4.1.
* gnu/packages/python-xyz.scm (python-asttokens): Update to 2.4.1. [build-system]: Swap to pyproject-build-system. [native-inputs]: Add python-setuptools and python-wheel. Change-Id: I95381f41e6e09d65ee0bfcef4c39d39a658a7607
-rw-r--r--gnu/packages/python-xyz.scm16
1 files changed, 11 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6eb1b79ecd..8c70b93718 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13218,16 +13218,22 @@ to Python code.")
(define-public python-asttokens
(package
(name "python-asttokens")
- (version "2.2.1")
+ (version "2.4.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "asttokens" version))
(sha256
- (base32 "1wwlpvnrh67z4228841zgpqc46vigslzmbvk2izbfc3g585i28j6"))))
- (build-system python-build-system)
- (propagated-inputs (list python-six))
- (native-inputs (list python-astroid python-pytest python-setuptools-scm))
+ (base32 "182b4l8sys07a46icg68h7b3d8iqkzvgsjqkgq1fp9m9idqnjf5h"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-astroid
+ python-pytest
+ python-setuptools
+ python-setuptools-scm
+ python-wheel))
+ (propagated-inputs
+ (list python-six))
(home-page "https://github.com/gristlabs/asttokens")
(synopsis "Python library to annotate abstract syntax trees")
(description "The @code{asttokens} module annotates Python abstract syntax