aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-18 16:07:41 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:08 +0200
commit18f6ab04e9de69fd805295e9ec6249c554008625 (patch)
tree9b14ba72f6b5a315b90514ad987ae1a406354478
parent7c92f707445b3826efa28f1e465df726d8fad287 (diff)
downloadguix-18f6ab04e9de69fd805295e9ec6249c554008625.tar.gz
guix-18f6ab04e9de69fd805295e9ec6249c554008625.zip
gnu: Add texlive-fancyref.
* gnu/packages/tex.scm (texlive-fancyref): New variable.
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a9ac2d9afc..35c42d037c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6089,6 +6089,27 @@ would automatically change the heading style in use).")
(define-deprecated-package texlive-latex-fancyhdr texlive-fancyhdr)
+(define-public texlive-fancyref
+ (package
+ (name "texlive-fancyref")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/fancyref/"
+ "source/latex/fancyref/"
+ "tex/latex/fancyref/")
+ (base32
+ "0njgl53f5farwbd8xkw8im8id0scf6agbfqcdjkbqlk540vdzwbp")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/fancyref")
+ (synopsis "LaTeX package for fancy cross-referencing")
+ (description
+ "This package provides fancy cross-referencing support, based on the
+package's reference commands (@code{\\fref} and @code{\\Fref}) that recognise
+what sort of object is being referenced.")
+ (license license:gpl3+)))
+
(define-public texlive-float
(package
(name "texlive-float")