aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2025-03-02 15:07:37 +0200
committerEfraim Flashner <efraim@flashner.co.il>2025-03-02 16:43:41 +0200
commit17b7b1a5cf1339bc5455c1576bb6431e9b3b23ff (patch)
tree93d23ed9605e55a00778d61dfd0831f2da02b230
parent61ca5bdbce55c38615b6f98a1835fa64b5220a7b (diff)
downloadguix-17b7b1a5cf1339bc5455c1576bb6431e9b3b23ff.tar.gz
guix-17b7b1a5cf1339bc5455c1576bb6431e9b3b23ff.zip
gnu: Remove unreferenced patches.
* gnu/packages/patches/cyrus-sasl-ac-try-run-fix.patch, gnu/packages/patches/gcc-10-tree-sra-union-handling.patch, gnu/packages/patches/gegl-compatibility-old-librsvg.patch: Remove files. Change-Id: Ic1e502ef44ac3e8645d813e50018a0ca2c8be706
-rw-r--r--gnu/packages/patches/cyrus-sasl-ac-try-run-fix.patch12
-rw-r--r--gnu/packages/patches/gcc-10-tree-sra-union-handling.patch33
-rw-r--r--gnu/packages/patches/gegl-compatibility-old-librsvg.patch80
3 files changed, 0 insertions, 125 deletions
diff --git a/gnu/packages/patches/cyrus-sasl-ac-try-run-fix.patch b/gnu/packages/patches/cyrus-sasl-ac-try-run-fix.patch
deleted file mode 100644
index 8662e812e9..0000000000
--- a/gnu/packages/patches/cyrus-sasl-ac-try-run-fix.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/m4/sasl2.m4 2018-11-18 22:33:29.902625600 +0300
-+++ b/m4/sasl2.m4 2018-11-18 22:33:59.828746176 +0300
-@@ -339,7 +339,8 @@
- ],
- [ AC_DEFINE(HAVE_GSS_SPNEGO,,[Define if your GSSAPI implementation supports SPNEGO])
- AC_MSG_RESULT(yes) ],
-- AC_MSG_RESULT(no))
-+ AC_MSG_RESULT(no),
-+ AC_MSG_RESULT(no))
- LIBS="$cmu_save_LIBS"
-
- else
diff --git a/gnu/packages/patches/gcc-10-tree-sra-union-handling.patch b/gnu/packages/patches/gcc-10-tree-sra-union-handling.patch
deleted file mode 100644
index aae5fc9f72..0000000000
--- a/gnu/packages/patches/gcc-10-tree-sra-union-handling.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-Fix a regression in GCC 10/11/12 where some union structures
-could get miscompiled when optimizations are enabled:
-
- https://gcc.gnu.org/bugzilla/show_bug.cgi?id=105860
-
-Taken from upstream:
-
- https://gcc.gnu.org/g:16afe2e2862f3dd93c711d7f8d436dee23c6c34d
-
-diff --git a/gcc/tree-sra.c b/gcc/tree-sra.c
-index 09d951a261b..420329f63f6 100644
---- a/gcc/tree-sra.c
-+++ b/gcc/tree-sra.c
-@@ -1647,7 +1647,18 @@ build_ref_for_offset (location_t loc, tree base, poly_int64 offset,
- static tree
- build_reconstructed_reference (location_t, tree base, struct access *model)
- {
-- tree expr = model->expr, prev_expr = NULL;
-+ tree expr = model->expr;
-+ /* We have to make sure to start just below the outermost union. */
-+ tree start_expr = expr;
-+ while (handled_component_p (expr))
-+ {
-+ if (TREE_CODE (TREE_TYPE (TREE_OPERAND (expr, 0))) == UNION_TYPE)
-+ start_expr = expr;
-+ expr = TREE_OPERAND (expr, 0);
-+ }
-+
-+ expr = start_expr;
-+ tree prev_expr = NULL_TREE;
- while (!types_compatible_p (TREE_TYPE (expr), TREE_TYPE (base)))
- {
- if (!handled_component_p (expr))
diff --git a/gnu/packages/patches/gegl-compatibility-old-librsvg.patch b/gnu/packages/patches/gegl-compatibility-old-librsvg.patch
deleted file mode 100644
index 3e5733f9fd..0000000000
--- a/gnu/packages/patches/gegl-compatibility-old-librsvg.patch
+++ /dev/null
@@ -1,80 +0,0 @@
-From a99a93e5c9013bd4101f5058cdee7d0cf30234fe Mon Sep 17 00:00:00 2001
-Message-ID: <a99a93e5c9013bd4101f5058cdee7d0cf30234fe.1694554961.git.vivien@planete-kraus.eu>
-From: Jehan <jehan@girinstud.io>
-Date: Wed, 5 Jul 2023 21:18:19 +0200
-Subject: [PATCH] Issue #333: continuing to support librsvg 2.40.x (C
- versions).
-
-Commit 9beeefcbe uses too new functions of librsvg. We could just bump
-the minimum required version but there are issues with Rust not being
-available on every platform yet. So instead, let's add some conditional
-code paths, so that it still builds with librsvg 2.40.x (which was the
-last versions fully in C) while we use newer code and no warnings when
-using newer versions.
----
- operations/external/svg-load.c | 25 ++++++++++++++++++++-----
- 1 file changed, 20 insertions(+), 5 deletions(-)
-
-diff --git a/operations/external/svg-load.c b/operations/external/svg-load.c
-index 3312a0c0a..15c0b30b7 100644
---- a/operations/external/svg-load.c
-+++ b/operations/external/svg-load.c
-@@ -76,16 +76,25 @@ query_svg (GeglOperation *operation)
- {
- GeglProperties *o = GEGL_PROPERTIES (operation);
- Priv *p = (Priv*) o->user_data;
-+#if LIBRSVG_CHECK_VERSION(2, 52, 0)
- gdouble out_width, out_height;
-+#else
-+ RsvgDimensionData dimensions;
-+#endif
-
- g_return_val_if_fail (p->handle != NULL, FALSE);
-
-- rsvg_handle_get_intrinsic_size_in_pixels (p->handle, &out_width, &out_height);
--
- p->format = babl_format ("R'G'B'A u8");
-
-+#if LIBRSVG_CHECK_VERSION(2, 52, 0)
-+ rsvg_handle_get_intrinsic_size_in_pixels (p->handle, &out_width, &out_height);
- p->height = out_height;
-- p->width = out_width;
-+ p->width = out_width;
-+#else
-+ rsvg_handle_get_dimensions (p->handle, &dimensions);
-+ p->height = dimensions.height;
-+ p->width = dimensions.width;
-+#endif
-
- return TRUE;
- }
-@@ -98,10 +107,12 @@ load_svg (GeglOperation *operation,
- {
- GeglProperties *o = GEGL_PROPERTIES (operation);
- Priv *p = (Priv*) o->user_data;
-- RsvgRectangle svg_rect = {0.0, 0.0, width, height};
- cairo_surface_t *surface;
- cairo_t *cr;
-- GError *error = NULL;
-+#if LIBRSVG_CHECK_VERSION(2, 52, 0)
-+ GError *error = NULL;
-+ RsvgRectangle svg_rect = {0.0, 0.0, width, height};
-+#endif
-
- g_return_val_if_fail (p->handle != NULL, -1);
-
-@@ -115,7 +126,11 @@ load_svg (GeglOperation *operation,
- (double)height / (double)p->height);
- }
-
-+#if LIBRSVG_CHECK_VERSION(2, 52, 0)
- rsvg_handle_render_document (p->handle, cr, &svg_rect, &error);
-+#else
-+ rsvg_handle_render_cairo (p->handle, cr);
-+#endif
-
- cairo_surface_flush (surface);
-
---
-2.41.0
-