aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-10 00:53:47 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:53 +0000
commit170f4a3125a95856e1bc6187eea166e5297749a9 (patch)
tree26fbc94ccba7a35a07f3caecbc4da57bc30fae72
parent345068655bbabeabbe4baa2eed4c743f73b72bbb (diff)
downloadguix-170f4a3125a95856e1bc6187eea166e5297749a9.tar.gz
guix-170f4a3125a95856e1bc6187eea166e5297749a9.zip
gnu: python-docspec-python: Move to pyproject-build-system.
* gnu/packages/python-xyz.scm (python-docspec-python): [build-system]: Move to pyproject-build-system. [arguments]<#:phases>: Remove uneeded field. Change-Id: Ib728c442a130eecebe4dff1e364d997bcca76076 Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 2 insertions, 10 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 33917e2d6d..b31a5b821f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -901,16 +901,8 @@ documentation of programming languages.")
(base32 "0n8m52vxmlvkj7p5jmd4rfdks65rrp4q4vzak44y6kbg9l5qa6y4"))))
(build-system pyproject-build-system)
(arguments
- (list
- #:tests? #false ;there are none
- #:phases
- '(modify-phases %standard-phases
- (add-after 'unpack 'relax-requirements
- (lambda _
- ;; We don't have black 23.
- (substitute* "pyproject.toml"
- (("23.1.0") "22.3.0")))))))
- (propagated-inputs (list python-black python-docspec python-nr-util))
+ (list #:tests? #false)) ;there are none
+ (propagated-inputs (list python-docspec python-nr-util))
(native-inputs (list python-poetry-core))
(home-page "https://github.com/NiklasRosenstein/docspec/")
(synopsis "Produce docspec data from Python source code")