aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZheng Junjie <z572@z572.online>2025-02-06 22:41:55 +0800
committerZheng Junjie <z572@z572.online>2025-02-15 20:06:43 +0800
commit169ef7616b376c6047dcaa14c7c208504e3b49be (patch)
tree7dc9e185d0e9d39e1029d1871b5fb109c7041c45
parent0cd02f5e083abac280f6478cb8fda16a0a02e789 (diff)
downloadguix-169ef7616b376c6047dcaa14c7c208504e3b49be.tar.gz
guix-169ef7616b376c6047dcaa14c7c208504e3b49be.zip
gnu: opensmtpd: Set sysconfdir to /etc.
* gnu/packages/mail.scm (opensmtpd)[arguments]<#:configure-flags>: Add --sysconfdir=/etc. <#:phases>: Add fix-smtpd.conf-install-path phase. Reviewed-by: 宋文武 <iyzsong@envs.net> Change-Id: I949b8ec18e36b059cf3f56a109e750af1284b1d2
-rw-r--r--gnu/packages/mail.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index bcfdeab326..3e90b3d0b8 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -57,7 +57,7 @@
;;; Copyright © 2023 Wilko Meyer <w@wmeyer.eu>
;;; Copyright © 2024 Benjamin Slade <slade@lambda-y.net>
;;; Copyright © 2024 Jean Simard <woshilapin@tuziwo.info>
-;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2024, 2025 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2024 Ashish SHUKLA <ashish.is@lostca.se>
;;; Copyright © 2025 Tanguy Le Carrour <tanguy@bioneland.org>
;;; Copyright © 2025 Sharlatan Hellseher <sharlatanus@gmail.com>
@@ -3322,6 +3322,8 @@ from the Cyrus IMAP project.")
(list
#:configure-flags
#~(list "--localstatedir=/var"
+ ;; Allow work with /etc/mailname.
+ "--sysconfdir=/etc"
"--with-libbsd"
;; This is the default only if it exists at build time—it doesn't.
"--with-path-socket=/var/run"
@@ -3352,6 +3354,15 @@ from the Cyrus IMAP project.")
(("/bin/cat" file) (search-input-file inputs file)))
(substitute* "usr.sbin/smtpd/mda_unpriv.c"
(("/bin/sh" file) (search-input-file inputs file)))))
+ ;; Avoid install smtpd.conf to /etc.
+ (add-after 'unpack 'fix-smtpd.conf-install-path
+ (lambda _
+ (let ((etc (string-append (assoc-ref %outputs "out")
+ "/etc")))
+ (mkdir-p etc)
+ (substitute* "mk/smtpd/Makefile.am"
+ (("\\$\\(DESTDIR\\)\\$\\(sysconfdir\\)/smtpd\\.conf")
+ (string-append etc "/smtpd.conf"))))))
;; OpenSMTPD provides a single smtpctl utility to control both the
;; daemon and the local submission subsystem. To accomodate systems
;; that require historical interfaces such as sendmail, newaliases or