aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-07-11 11:18:02 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-07-11 11:18:02 +0200
commit157139612a34660679f827996f781a605cb1bed5 (patch)
tree330a47c3c5c6a66b6a45bbedd7deedf6b178fa4f
parent7093824be088760ac2be1107582de419d03e0351 (diff)
downloadguix-157139612a34660679f827996f781a605cb1bed5.tar.gz
guix-157139612a34660679f827996f781a605cb1bed5.zip
gnu: emacs-doom-themes: Update to 2.3.0.
* gnu/packages/emacs-xyz.scm (emacs-doom-themes): Update to 2.3.0.
-rw-r--r--gnu/packages/emacs-xyz.scm77
1 files changed, 37 insertions, 40 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3da27434da..2dab2f40c6 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -28012,47 +28012,44 @@ contrast and few colors.")
(license license:gpl3+))))
(define-public emacs-doom-themes
- (let ((commit "e9bdd137116fa2037ed60037b8421cf68c64888d")
- (revision "6")
- (version "2.1.6"))
- (package
- (name "emacs-doom-themes")
- (version (git-version version revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/hlissner/emacs-doom-themes")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "178ri980kwkndb73dawhsfr1dkl6xjdb451z0iar9ghk8z0r0wpg"))))
- (build-system emacs-build-system)
- (native-inputs
- (list emacs-ert-runner))
- (arguments
- `(#:tests? #t
- #:test-command '("ert-runner")
- #:modules ((guix build emacs-build-system)
- (guix build utils)
- (guix build emacs-utils)
- (srfi srfi-1))
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'move-themes
- (lambda _
- ;; Move the source files to the top level, which is in the
- ;; EMACSLOADPATH.
- (for-each (lambda (f)
- (rename-file f (basename f)))
- (append
- (find-files "./themes" ".*\\.el$")
- (find-files "./extensions" ".*\\.el$")))
- #t)))))
- (synopsis "Wide collection of color themes for Emacs")
- (description "Emacs-doom-themes contains numerous popular color themes for
+ (package
+ (name "emacs-doom-themes")
+ (version "2.3.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hlissner/emacs-doom-themes")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "120pcas0l1m6w551qxfcl2fx0aysjqp91nn47zdxrr8rs01654wr"))))
+ (build-system emacs-build-system)
+ (native-inputs
+ (list emacs-ert-runner))
+ (arguments
+ `(#:tests? #t
+ #:test-command '("ert-runner")
+ #:modules ((guix build emacs-build-system)
+ (guix build utils)
+ (guix build emacs-utils)
+ (srfi srfi-1))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'move-themes
+ (lambda _
+ ;; Move the source files to the top level, which is in the
+ ;; EMACSLOADPATH.
+ (for-each (lambda (f)
+ (rename-file f (basename f)))
+ (append
+ (find-files "./themes" ".*\\.el$")
+ (find-files "./extensions" ".*\\.el$")))
+ #t)))))
+ (synopsis "Wide collection of color themes for Emacs")
+ (description "Emacs-doom-themes contains numerous popular color themes for
Emacs that integrate with major modes like Org-mode.")
- (home-page "https://github.com/hlissner/emacs-doom-themes")
- (license license:expat))))
+ (home-page "https://github.com/hlissner/emacs-doom-themes")
+ (license license:expat)))
(define-public emacs-modus-themes
(package