aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLiam Hupfer <liam@hpfr.net>2025-02-23 13:55:50 -0600
committerIan Eure <ian@retrospec.tv>2025-02-24 21:37:16 -0800
commit150df457d1e269790f184510c58d031ee00a9ebb (patch)
treeeaff5b567c56558c8bc57b1820168cd47003525c
parentc1cab99ff8fb6f67e815ab9a6bd25768ac2c77cf (diff)
downloadguix-150df457d1e269790f184510c58d031ee00a9ebb.tar.gz
guix-150df457d1e269790f184510c58d031ee00a9ebb.zip
gnu: emacs-ws-butler: Update to 1.1 from new maintainer.
The original author of ws-butler is largely inactive. Sean Whitton has taken over maintenance at NonGNU ELPA and applied several outstanding patches. ELPA tarballs do not deploy tests, so remove test support and rely on upstream in alignment with other packages sourced from NonGNU ELPA. While we’re here, tidy the package docs and run guix style. * gnu/packages/emacs-xyz.scm (emacs-ws-butler): Update to 1.1 from new maintainer. Link: https://github.com/lewang/ws-butler/issues/52 Link: https://github.com/lewang/ws-butler/issues/58 Change-Id: I09db3d855c4b15d2253090884106e00bc1719607 Signed-off-by: Ian Eure <ian@retrospec.tv>
-rw-r--r--gnu/packages/emacs-xyz.scm26
1 files changed, 10 insertions, 16 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6f803e2df6..6bd6cec67d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -22523,27 +22523,21 @@ of commands is displayed in a handy popup.")
(define-public emacs-ws-butler
(package
(name "emacs-ws-butler")
- (version "0.7")
+ (version "1.1")
(source
(origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/lewang/ws-butler")
- (commit "v0.7")))
- (file-name (git-file-name name version))
+ (method url-fetch)
+ (uri (string-append "https://elpa.nongnu.org/nongnu/ws-butler-" version
+ ".tar"))
(sha256
- (base32 "17f73isx2wdwzjcxparyy7ngl4cha0g69da1d72b3yidzim1kh6h"))))
+ (base32 "1vy7g2ryg1drcz9zpn011d36zcd9a5b5yny5hwpjrllqj5dg73jx"))))
(build-system emacs-build-system)
- (arguments
- `(#:tests? #t
- #:test-command '("ert-runner" "tests")))
- (native-inputs
- (list emacs-ert-runner))
- (home-page "https://github.com/lewang/ws-butler")
- (synopsis "Trim spaces from end of lines")
+ (home-page "https://elpa.nongnu.org/nongnu/ws-butler.html")
+ (synopsis "Unobtrusively remove trailing whitespace")
(description
- "This Emacs package automatically and unobtrusively trims whitespace
-characters from end of lines.")
+ "ws-butler automatically trims trailing whitespace characters on save.
+In contrast with other whitespace cleanup solutions, only modified lines are
+trimmed.")
(license license:gpl3+)))
(define-public emacs-opencl-mode