aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-22 21:13:05 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:53 +0000
commit14f80884f79ffe01ffb80704b6add1ee1bfb949c (patch)
tree9416427893e91ae4bf9dde1e5715608afc770cae
parentd83434fc5b57a4d08d5a9e4b2de9a3055f5e0d92 (diff)
downloadguix-14f80884f79ffe01ffb80704b6add1ee1bfb949c.tar.gz
guix-14f80884f79ffe01ffb80704b6add1ee1bfb949c.zip
gnu: Add go-github-com-prometheus-community-pro-bing.
* gnu/packages/prometheus.scm (go-github-com-prometheus-community-pro-bing): New variable. Change-Id: Ifc536d497396b02671ff44f4845c43dfba893d4d
-rw-r--r--gnu/packages/prometheus.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/prometheus.scm b/gnu/packages/prometheus.scm
index 3e3a51b805..c498c27030 100644
--- a/gnu/packages/prometheus.scm
+++ b/gnu/packages/prometheus.scm
@@ -366,6 +366,39 @@ using Amazon's Signature Verification V4 signing procedure, using credentials
from the default AWS credential chain.")
(license license:asl2.0)))
+(define-public go-github-com-prometheus-community-pro-bing
+ (package
+ (name "go-github-com-prometheus-community-pro-bing")
+ (version "0.4.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/prometheus-community/pro-bing")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1yz4cf1qrm1jrzw2yd5p08663hynk4ihlf5mi2fn6irnzh343a7b"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ ;; Tests requiring network setup.
+ #:test-flags
+ #~(list "-skip" (string-append "TestNewPingerValid"
+ "|TestSetIPAddr"
+ "|TestSetResolveTimeout"))
+ #:import-path "github.com/prometheus-community/pro-bing"))
+ (propagated-inputs
+ (list go-github-com-google-uuid
+ go-golang-org-x-net
+ go-golang-org-x-sync))
+ (home-page "https://github.com/prometheus-community/pro-bing")
+ (synopsis "Continuous probers Golang library")
+ (description
+ "This package implements @acronym{Internet Control Message
+Protocol,ICMP} echo (ping) functionality.")
+ (license license:expat)))
+
(define-public go-github-com-prometheus-exporter-toolkit
(package
(name "go-github-com-prometheus-exporter-toolkit")