aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2025-02-27 08:47:14 +0100
committerRicardo Wurmus <rekado@elephly.net>2025-02-27 09:59:49 +0100
commit1456c7782fa0b48a16c59a62cdf478357e11c492 (patch)
treee88a98b97825aac64477e1e87fc02dab4159ecf3
parentdc8e5343f81660b453a89e1059a7930bbdb66592 (diff)
downloadguix-1456c7782fa0b48a16c59a62cdf478357e11c492.tar.gz
guix-1456c7782fa0b48a16c59a62cdf478357e11c492.zip
gnu: python-thinc: Update to 8.1.12.
* gnu/packages/machine-learning.scm (python-thinc): Update to 8.1.12. [propagated-inputs]: Remove python-contextvars and python-typing-extensions; replace python-pydantic with python-pydantic-2. Change-Id: I7d79791163a750896495b4fed919c312b1110614
-rw-r--r--gnu/packages/machine-learning.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index da301aa17f..fbdd913116 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -2079,13 +2079,13 @@ and are compatible with its API.")
(define-public python-thinc
(package
(name "python-thinc")
- (version "8.1.10")
+ (version "8.1.12")
(source (origin
(method url-fetch)
(uri (pypi-uri "thinc" version))
(sha256
(base32
- "14drmwa2sh8fqszv1fm2jl4lky1j5yrbkjv89bl49q07vbblhjkc"))))
+ "0lx37vl84y2jcsfn9sphdzbjny2jjyfb85llrrvz0xmig5f2rlcx"))))
(build-system pyproject-build-system)
(arguments
'(#:phases
@@ -2097,15 +2097,14 @@ and are compatible with its API.")
(propagated-inputs (list python-blis-for-thinc
python-catalogue
python-confection
- python-contextvars
python-cymem
python-murmurhash
python-numpy
python-packaging
python-preshed
- python-pydantic
+ python-pydantic-2
+ python-setuptools
python-srsly
- python-typing-extensions
python-wasabi))
(native-inputs (list python-cython python-mock python-pytest
python-setuptools python-wheel))