aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-02-28 20:34:09 +0200
committerEfraim Flashner <efraim@flashner.co.il>2017-02-28 21:01:26 +0200
commit13e4a6c8636779e26de52c796ea75832c71826a2 (patch)
tree98f219dd78beb05311ccfcd64666c304ded10df7
parent05740895feebfbbedc3f20968ac172b85b90b1de (diff)
downloadguix-13e4a6c8636779e26de52c796ea75832c71826a2.tar.gz
guix-13e4a6c8636779e26de52c796ea75832c71826a2.zip
gnu: screen: Update to 4.5.1.
* gnu/packages/screen.scm (screen): Update to 4.5.1. [source]: Remove patch. * gnu/packages/patches/screen-CVE-2017-5618.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/screen-CVE-2017-5618.patch40
-rw-r--r--gnu/packages/screen.scm6
3 files changed, 2 insertions, 45 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index b408cc29d9..f356a124b3 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -893,7 +893,6 @@ dist_patch_DATA = \
%D%/packages/patches/sed-hurd-path-max.patch \
%D%/packages/patches/scheme48-tests.patch \
%D%/packages/patches/scotch-test-threading.patch \
- %D%/packages/patches/screen-CVE-2017-5618.patch \
%D%/packages/patches/sdl-libx11-1.6.patch \
%D%/packages/patches/seq24-rename-mutex.patch \
%D%/packages/patches/serf-comment-style-fix.patch \
diff --git a/gnu/packages/patches/screen-CVE-2017-5618.patch b/gnu/packages/patches/screen-CVE-2017-5618.patch
deleted file mode 100644
index 1b95e428c8..0000000000
--- a/gnu/packages/patches/screen-CVE-2017-5618.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-Fixes CVE-2017-5618 (privilege escalation via opening the logfile when
-screen is installed setuid root):
-
-https://savannah.gnu.org/bugs/?50142
-https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-5618
-
-This patch reverts the upstream commit that introduced the bug:
-
-https://git.savannah.gnu.org/cgit/screen.git/commit/?id=5460f5d28c01a9a58e021eb1dffef2965e629d58
-
-From f55b0cc29a0ac2a1c54e8a5e886b7393edd4a76c Mon Sep 17 00:00:00 2001
-From: Leo Famulari <leo@famulari.name>
-Date: Sat, 11 Feb 2017 22:40:24 -0500
-Subject: [PATCH] Revert "adding permissions check for the logfile name"
-
-This reverts commit 5460f5d28c01a9a58e021eb1dffef2965e629d58.
----
- src/screen.c | 6 ------
- 1 file changed, 6 deletions(-)
-
-diff --git a/src/screen.c b/src/screen.c
-index 64650e9..283c305 100644
---- a/src/screen.c
-+++ b/src/screen.c
-@@ -673,12 +673,6 @@ int main(int ac, char** av)
- Panic(0, "-L: logfile name can not start with \"-\" symbol");
- if (strlen(screenlogfile) > PATH_MAX)
- Panic(0, "-L: logfile name too long. (max. %d char)", PATH_MAX);
--
-- FILE *w_check;
-- if ((w_check = fopen(screenlogfile, "w")) == NULL)
-- Panic(0, "-L: logfile name access problem");
-- else
-- fclose(w_check);
- }
- nwin_options.Lflag = 1;
- break;
---
-2.11.1
-
diff --git a/gnu/packages/screen.scm b/gnu/packages/screen.scm
index 57e6cb595e..f5c914e88a 100644
--- a/gnu/packages/screen.scm
+++ b/gnu/packages/screen.scm
@@ -35,15 +35,13 @@
(define-public screen
(package
(name "screen")
- (version "4.5.0")
+ (version "4.5.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/screen/screen-"
version ".tar.gz"))
- (patches (search-patches "screen-CVE-2017-5618.patch"))
- (patch-flags '("-p2"))
(sha256
- (base32 "1c7grw03a9iwvqbxfd6hmjb681rp8gb55zsxm7b3apqqcb1sghq1"))))
+ (base32 "0bbv16gpxrh64sn4bvjy3qjy7jsxjlqlilyysin02fwnvla23nwp"))))
(build-system gnu-build-system)
(native-inputs
`(("makeinfo" ,texinfo)))
13adb27260ca68d'>gnu: python-oslo.utils: Update to 4.12.0....* gnu/packages/openstack.scm (python-oslo.utils): Update to 4.12.0. [arguments]: Override check phase. [propagated-inputs]: Remove PYTHON-MONOTONIC and PYTHON-SIX. Add PYTHON-PBR and PYTHON-PACKAGING-NEXT. [native-inputs]: Remove PYTHON-PBR, PYTHON-BANDIT, PYTHON-OSLO.CONFIG, PYTHON-MOCK and PYTHON-TESTREPOSITORY. Add PYTHON-STESTR. Marius Bakke 2022-01-12gnu: python-oslo.config: Update to 8.7.1....* gnu/packages/openstack.scm (python-oslo.config): Update to 8.7.1. [arguments]: Disable tests. [native-inputs]: Remove. [propagated-inputs]: Remove PYTHON-PBR and PYTHON-SIX. Add PYTHON-REQUESTS. Marius Bakke 2022-01-11gnu: python-os-testr: Add python-testrepository to inputs....This fixes a build failure in the 'sanity-check' phase. * gnu/packages/openstack.scm (python-os-testr)[native-inputs]: Add python-testrepository. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Tanguy Le Carrour 2022-01-11gnu: python-oslo.i18n: Disable tests....* gnu/packages/openstack.scm (python-oslo.i18n)[arguments]: Add #:tests?. [native-inputs]: Remove PYTHON-MOCK, PYTHON-MOX3, PYTHON-OSLOTEST, and PYTHON-TESTSCENARIOS. Marius Bakke 2022-01-11gnu: python-os-testr: Update to 2.0.1....* gnu/packages/openstack.scm (python-os-testr): Update to 2.0.1. [propagated-inputs]: Change from PYTHON-SUBUNIT to PYTHON-STESTR. Marius Bakke 2021-12-13gnu: Simplify package inputs....This commit was obtained by running: ./pre-inst-env guix style without any additional argument. Ludovic Courtès 2021-11-11gnu: Move a few Python packages to (gnu packages python-build)....This is in prevision of updating python-pypa-build, which now requires python-packaging and adding python-tomli, which requires python-six. * gnu/packages/python-xyz.scm (python-six) (python-six-bootstrap, python2-six-bootstrap) (python-pyparsing, python2-pyparsing, python-pyparsing-2.4.7) (python-packaging-bootstrap, python2-packaging-bootstrap): Move packages to... * gnu/packages/python-build.scm: ... here. Update python-parsing to latest. * gnu/packages/python-xyz.scm (python-six, python-packaging): Adjust to inherit from their bootstrap versions. Maxim Cournoyer 2021-10-13gnu: python-git-review: Update to 2.1.0....* gnu/packages/openstack.scm (python-git-review): Update to 2.1.0. Clément Lassieur