aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-15 19:11:20 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:31 +0200
commit12a1332fb6795ff2e48d0402567a995836fa5f26 (patch)
tree0ebca97232d9dca633e8c4ee816cf0c40a94de36
parent3eb88e656b79b08a2e2e6024ea41e7f1e0da6a27 (diff)
downloadguix-12a1332fb6795ff2e48d0402567a995836fa5f26.tar.gz
guix-12a1332fb6795ff2e48d0402567a995836fa5f26.zip
gnu: texlive-arev: Refresh package definition.
* gnu/packages/tex.scm (texlive-arev): Remove SIMPLE-TEXLIVE-PACKAGE call. [propagated-inputs]: Add TEXLIVE-AMSFONTS, TEXLIVE-BERA.
-rw-r--r--gnu/packages/tex.scm61
1 files changed, 34 insertions, 27 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a2db444b37..8645b767bf 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11085,34 +11085,41 @@ the @code{psnfss} distribution.")
(define-public texlive-arev
(package
- (inherit (simple-texlive-package
- "texlive-arev"
- (list "/doc/fonts/arev/"
- "/fonts/afm/public/arev/"
- "/fonts/enc/dvips/arev/"
- "/fonts/map/dvips/arev/"
- "/fonts/tfm/public/arev/"
- "/fonts/type1/public/arev/"
- "/fonts/vf/public/arev/"
- "/tex/latex/arev/")
- (base32
- "15wkgc48r52mjpymv6l7j9bl99kwxbvg3g1mi3qyq7nfm799dkxy")
- #:trivial? #t))
- (home-page "https://www.ctan.org/pkg/arev")
+ (name "texlive-arev")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/fonts/arev/"
+ "fonts/afm/public/arev/"
+ "fonts/enc/dvips/arev/"
+ "fonts/map/dvips/arev/"
+ "fonts/tfm/public/arev/"
+ "fonts/type1/public/arev/"
+ "fonts/vf/public/arev/"
+ "source/fonts/arev/"
+ "tex/latex/arev/")
+ (base32
+ "1a0zw9vc6z0shxvb4kdhfqdhwpzph5hm9v7klpchlisabvk421y1")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (propagated-inputs
+ (list texlive-amsfonts
+ texlive-bera))
+ (home-page "https://ctan.org/pkg/arev")
(synopsis "Fonts and LaTeX support files for Arev Sans")
- (description "The @code{arev} package provides type 1 fonts,
-virtual fonts and LaTeX packages for using Arev Sans in both text and
-mathematics. Arev Sans is a derivative of Bitstream Vera Sans, adding
-support for Greek and Cyrillic characters and a few variant letters
-appropriate for mathematics. The font is primarily used in LaTeX for
-presentations, particularly when using a computer projector. Arev
-Sans has large x-height, \"open letters\", wide spacing and thick
-stems. The style is very similar to the SliTeX font lcmss but
-heavier. Arev is one of a very small number of sans-font mathematics
-support packages. Others are cmbright, hvmath and kerkis.")
- (license (list license:silofl1.1 ;for Arev Sans
- license:lppl1.3a ;for TeX support files
- license:gpl2)))) ;for ams-mdbch.sty
+ (description
+ "The @code{arev} package provides type 1 fonts, virtual fonts and LaTeX
+packages for using Arev Sans in both text and mathematics. Arev Sans is
+a derivative of Bitstream Vera Sans, adding support for Greek and Cyrillic
+characters and a few variant letters appropriate for mathematics. The font is
+primarily used in LaTeX for presentations, particularly when using a computer
+projector. Arev Sans has large x-height, open letters, wide spacing and thick
+stems. The style is very similar to the SliTeX font @code{lcmss} but heavier.
+Arev is one of a very small number of sans-font mathematics support
+packages.")
+ (license (list license:silofl1.1 ;for Arev Sans
+ license:lppl1.3a ;for TeX support files
+ license:gpl2)))) ;for ams-mdbch.sty
(define-public texlive-mathdesign
(package